Перейти к содержимому


Фотография

CGMINER

CGMINER miner цгмайнер майнер цгминер

  • Авторизуйтесь для ответа в теме
Сообщений в теме: 3429

#701 Volzhanin

Volzhanin

    Новичок

  • Пользователи
  • Pip
  • 43 сообщений

Отправлено 05 May 2013 - 20:31

AlxSm, я пытался настраивать по редмишнику, где тоже написано, что вектор и gpu-threads можно не указывать..делал укороченный батник cgminer --scrypt -o stratum+tcp://stratum.give-me-ltc.com:3333 -u *** -p *** --intensity 12 --thread-concurrency 8190 пробывал и постепенно менял значения и добавлял новые параметры..скорость от 260 до 305 была..при интенсивности 13 HW не было, но комп начинал жутко тормозить..при 14 - крашилось

сейчас всё нормально

Безымянный.jpg

Обнародуй частоты пожалуйста.

стоят по умолчанию 1050/1250..cgminer 2.10.5, win 7 x 64 HP, дрова 12.10, оперативы 8 гиг


Сообщение отредактировал Volzhanin: 05 May 2013 - 20:35

  • 0

#702 AlxSm

AlxSm

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 617 сообщений
  • ГородКинель, Самарская область

Отправлено 05 May 2013 - 20:33

Я тогда вообще не понимаю, как у некоторых работает на интенсивности -I 20...


  • 0

#703 Andrey69

Andrey69

    Пользователь

  • Пользователи
  • PipPip
  • 418 сообщений

Отправлено 05 May 2013 - 20:57

дрова 12.10

 

Хм... Может в дровах дело... У меня 13.1 стоят.


  • 0

#704 morpeh

morpeh

    Пользователь

  • Пользователи
  • PipPip
  • 75 сообщений

Отправлено 05 May 2013 - 21:02

Andrey69 , а у тебя сколько выдает kh/s ?

Сообщение отредактировал morpeh: 05 May 2013 - 21:03

  • 0

#705 Lexis77

Lexis77

    Дискурсмонгер

  • Администраторы
  • 13209 сообщений
  • ГородМосква

Отправлено 05 May 2013 - 22:36

1-переключал. Управление через тим-вивер. Не работают клавиши.

Сверни и разверни окно. Тоже периодически не срабатывало.


  • 1

#706 Pingui

Pingui

    Неизлечимый перфекционист

  • Пользователи
  • PipPipPip
  • 950 сообщений

Отправлено 05 May 2013 - 22:52

Я тогда вообще не понимаю, как у некоторых работает на интенсивности -I 20...

Насколько я знаю, для scrypt'a нужно много оперативной памяти. Может, чем больше видях на ферме, тем больше нужно памяти?


  • 0

#707 SaShaDelas

SaShaDelas

    Пользователь

  • Пользователи
  • PipPip
  • 154 сообщений

Отправлено 05 May 2013 - 22:55

Андрей, спасибо за отклик.

Карты указаны в моём предыдущем сообщении: "2x7970". Расскажу подробнее.

Все карты у меня производства ASUS. Все с заводским разгоном (версии "TOP"). Ссылка на сравнение с параметрами:

Собраны они так:

Комп GPU1 = 7950 + 7850 + 7950 (сверху вниз по слотам);

Комп GPU2 = 7970 + 7970;

Комп GPU3 = 7850;

Комп GPU4 = 7850.

Если есть необходимость, могу полные конфигурации платформ выложить.

И доп. параметры я уже разные в разных комбинация перепробывал. (bin-файлы удалял при изменении параметров.) Сейчас стал запускать вообще без доп. параметров. Только само подключение к пулу и интенсивность пробую разную. И так, и эдак — хоть убейся, на всех фермах HW-ошибки на интенсивности от 12-13 и выше. На 11-ой интенсивности вроде не заметил HW, хотя прям очень долго не ждал, ибо скорость на трети от расчётной по таблицам. На 12-ой интенсивности HW-ошибок меньше, но они однозначно есть, иногда очень даже редкие, иногда их частота возрастает. Частоты стоковые установлены.

Если это важно, то карты в мульти-GPU конфигурациях мостиками не соединены.

cgminer использую последний 3.1.0.

Итого для 7850 в одиночной конфигурации (на ней параметры тестирую) выдаёт всего 264 Кх/с. Для 2x7970 — столько же для каждой!

При этом по SHA256 всё работает стабильно, без HW и скорости практически совпадают с теми, что приводятся в известных таблицах.

Пробовал и с включенным и с выключенным LucidLogix в BIOS. И с активным экраном на AMD-карту(ы), и на встроенное видео, и с расширением рабочего стола и на встроенное видео + AMD. Ничего не помогает. Интенсивность маленькая = скорость маленькая. Повышение интенсивности приводит к HW. Об стену штоли их стукнуть.

Вот как-то так в общем.

Та же самая фигня у меня седня была, целый день провозился с ней и начитался статей разных... нашел свою золотую середину наверное.Вк тоже асус топ 1000/1400

cgminer --scrypt --intensity 13 -o http://litecoinpool.org:9332 -u логин -p пароль -g 2 --thread-concurrency 8192 --shaders 2048 --worksize 256

При таких параметрах выдает около 600-720Кх статистику смотрел на сайте , а то на майнере вроде как не совпадает с реальной картиной.... после 2 часового майна HW  было по нолям. И еще важно соотношение ГПУ и памяти должно быть больше 0.58, а лучше 0.68... И как так что у асуса при 1450 слетают дрова? наверное криво поставлены у меня при 1600 нормально работают

-thread-concurrency 8192 стоит еще с этим поигратся должно увеличить кпд  и агресию лучше не подымать больше 13 появляются HW



У меня работает и на 17-20 но HW много валить начинает где то в соотношении принятых шар 1 к 100 HW


  • 0

#708 SaShaDelas

SaShaDelas

    Пользователь

  • Пользователи
  • PipPip
  • 154 сообщений

Отправлено 05 May 2013 - 23:00

Я тогда вообще не понимаю, как у некоторых работает на интенсивности -I 20...

Насколько я знаю, для scrypt'a нужно много оперативной памяти. Может, чем больше видях на ферме, тем больше нужно памяти?

врят ли оперативки  надо много майнер жрет  до 150мб в работе , а вот видеопамяти где то 1600 уходит на работу


  • 0

#709 Andrey69

Andrey69

    Пользователь

  • Пользователи
  • PipPip
  • 418 сообщений

Отправлено 05 May 2013 - 23:24

И еще важно соотношение ГПУ и памяти должно быть больше 0.58, а лучше 0.68...

 

Вот оно! А я ищу уже около часа тот форум где когда-то краем глаза увидел этот коэффициент но не сохранил закладку.))) Спасибо!


  • 0

#710 AlxSm

AlxSm

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 617 сообщений
  • ГородКинель, Самарская область

Отправлено 05 May 2013 - 23:25

Pingui, так как у меня на любой из ферм плохие показатели скорости, то я провожу тестирование на компе, за которым работаю. На нём у меня одна ASUS 7850 + Intel HD 4000 для десктопа (рабочий стол расширен на оба видеоадаптера, основным включен Intel), чтобы артефакты не мучали. Я проверял в разных комбинациях, на HW не влияло включение или выключение функции LucidLogix в BIOS. Так вот памяти у меня на этом компе 16 GB. Сама же видеокарта своей видеопамяти потребляет 563 MB.

Спасибо, Andrey69, навёл на правильные действия, которые я в упор почему-то не замечал (понял почему не замечал, но это к делу вроде как не относится).

SaShaDelas, в общем всё верно говорится в SCRYPT-README.

Главное, в самом начале BAT-файла обязательно прописать значения переменных: (может быть не обе они нужны и/или с ними ещё можно поиграться, но для интенсивности мне сразу помогло и убрало HW)

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1

Для поиска наибольшего или лучшего значения --thread-concurrency, лучше всего убрать все параметры, кроме подключения к пулу. У меня нашлось наивысшее значение 12284, но оно вроде бы не оказалось лучшим. Для двух 7850, установленных в разных компах, для ~350 Кх/с оказался эффективным такой батник:

 

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
..\cgminer.exe --scrypt -o stratum+tcp://*** -u *** -p *** -I 18 --thread-concurrency 8192 --auto-fan
 

У одной карты интенсивность 18, у другой 19. С частотой памяти у меня и правда какая-то хрень: 1450 ставишь, может сбойнуть драйвер, но чаще работает, но если выше, то почему-то сразу же вылетает, но при низкой интенсивности (8 или d или если вообще не её указывать) — работает.
Наверное, можно и больше выжать, если покумекать, но пока меня устраивает. Это уже по крайней мере не нищенские 30-50% от возможных результатов по таблице.

Теперь мне нужно GPU1 и GPU2 также эффективно настроить, а вот с ними возникли трудности...


  • 0

#711 Andrey69

Andrey69

    Пользователь

  • Пользователи
  • PipPip
  • 418 сообщений

Отправлено 05 May 2013 - 23:26


Может, чем больше видях на ферме, тем больше нужно памяти?

 

Скорее всего это миф. У меня на двух фермах (одна с 2Гб оперативы, другая с 4Гб) стоят по 4 одинаковых видяхи - в плане хэшрейта результат одинаковый на обеих.


  • 0

#712 Andrey69

Andrey69

    Пользователь

  • Пользователи
  • PipPip
  • 418 сообщений

Отправлено 05 May 2013 - 23:32


Спасибо, Andrey69, навёл на правильные действия

 

Всегда пожалуйста, бро! :D Сам очень рад, что наконец-то победил этот (трижды вырезано цензурой) скрипт. Теперь еще поиграюсь с соотношением частоты ядра и памяти. Сначала выставил все по максимуму, но потом встретил конструктивное мнение, что ядро не так важно для скрипта, понизил немного, и скорость немного выросла!!! Чудеса...)


  • 0

#713 AlxSm

AlxSm

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 617 сообщений
  • ГородКинель, Самарская область

Отправлено 05 May 2013 - 23:42

Andrey69, и не говори, Scrypt по сравнению с SHA256 — эщадъе адово! Мало того, что этот сраный алгоритм искусственно занижен по производительности, так ещё и никто особо и не разбежался рассказать, как его хотя бы искусственно сделать близким к его возможной эффективности. Производители видеокарт, по моему глубокому убеждению, явно падлы, потому что вообще никак не способствуют эффективной настройке ими выпущенных устройств! А то, что дрова у AMD кривота-и-херота, я понял только после того, как стал майнером.


  • 0

#714 Andrey69

Andrey69

    Пользователь

  • Пользователи
  • PipPip
  • 418 сообщений

Отправлено 05 May 2013 - 23:54

Производители видеокарт, по моему глубокому убеждению, явно падлы, потому что вообще никак не способствуют эффективной настройке ими выпущенных устройств!

 

Ну, по сути так они видеокарты для геймеров делают, а не для майнеров.))) Плохо только то, что брат наш (майнер) в основном жадный до предела. Только хвастаются все сколько у них мега или кило выходит с карты, а подсказать с настройками так пшел вон... Вот что немного обидно.


  • 0

#715 zake

zake

    Новичок

  • Пользователи
  • Pip
  • 10 сообщений

Отправлено 06 May 2013 - 00:48

Делал по faq http://btcsec.com/passive_income/ при запуске батника cgminer закрывается с ошибкой. error1.png

 

Если запускать без батника, программа запускается и просит URL пула, потом логин, потом пароль, а потом виснет)

 

Видел в этой ветке, что запуск с совместимостью с win xp (SP2/SP3) может помочь - мне не помогло.

 

Что может быть не так? С чего начать?

Пытался запустить батником (run.cmd) с командами 

 

cgminer.exe --syslog
 

или 

 

cgminer.exe --debug
 

Но не понял куда информация выводится, окошко просто исчезает, никаких логов в папке вроде не появилось. Я не правильно задаю эти команды?)


  • 0

#716 AlxSm

AlxSm

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 617 сообщений
  • ГородКинель, Самарская область

Отправлено 06 May 2013 - 00:52

zake, Выполнить - cmd - cgminer -n, покажи, что напишет.


  • 0

#717 zake

zake

    Новичок

  • Пользователи
  • Pip
  • 10 сообщений

Отправлено 06 May 2013 - 01:08

C:\Users\Zakebro>c:\cgminer\cgminer.exe -n
 [2013-05-05 02:07:28] CL Platform 0 vendor: Advanced Micro Devices, Inc.
 [2013-05-05 02:07:28] CL Platform 0 name: AMD Accelerated Parallel Processing
 [2013-05-05 02:07:28] CL Platform 0 version: OpenCL 1.2 AMD-APP (1124.2)
 [2013-05-05 02:07:28] Platform 0 devices: 1
 [2013-05-05 02:07:28]  0       Cypress
 [2013-05-05 02:07:28] Failed to ADL_Adapter_ID_Get. Error -1


 [2013-05-05 02:07:28] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-05-05 02:07:28] GPU 0 ATI Radeon HD 5800 Series hardware monitoring enabl
ed
 [2013-05-05 02:07:28] 1 GPU devices max detected
 [2013-05-05 02:07:28] USB all: found 6 devices - listing known devices
 [2013-05-05 02:07:28] No known USB devices
 

  • 0

#718 AlxSm

AlxSm

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 617 сообщений
  • ГородКинель, Самарская область

Отправлено 06 May 2013 - 01:27

zake, какая версия драйверов стоит?


  • 0

#719 zake

zake

    Новичок

  • Пользователи
  • Pip
  • 10 сообщений

Отправлено 06 May 2013 - 01:30

На другом компе, где видюха NVIDIA GT610 запустилось сразу, но скорость ужасная в 8Мхешей, а на норм компе с АМД не запускается.

 

По поиску нашел две похожие темы в инете "failed to adl_adapter_id_get" там у людей проблемы с запуском двух видюх от амд и нвидиа совместно.

Отключил интегрированную в проц(Intel) видеокарту - не помогло :D



zake, какая версия драйверов стоит?

Драйвера последние. 13,4 для 64-разрядных систем.


  • 0

#720 AlxSm

AlxSm

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 617 сообщений
  • ГородКинель, Самарская область

Отправлено 06 May 2013 - 01:38

zake, у тебя пока всё должно работать, но у тебя Radeon 58xx-серии, поэтому, возможно, тебе придётся помаркетанить с версией AMD APP SDK. Удали через Catalyst все AMD'шные драйвера, перезагрузись, затем установи дрова 13.1, скажем. В нём есть драйвера APP SDK 2.7 (OpenCL 1.2 AMD-APP (1016.4)). Я ставлю без Каталист Контрол Центр. Возможно, придётся попробовать откатиться на версию SDK 2.6 или 2.5.


  • 0





Темы с аналогичным тегами CGMINER, miner, цгмайнер, майнер, цгминер

Количество пользователей, читающих эту тему: 11

0 пользователей, 8 гостей, 0 анонимных


    Bing (2), Yandex (1)