Перейти к содержимому
demon_17

Cgminer и видеокарты GeForce 570 и HD7950

Рекомендуемые сообщения

Всем добрый день, хоть тема уже и поднималась, решение своей проблемы никак не могу найти.

Суть: у меня установлены две видеокарты: GeForce GTX 570, HD 7950. Я хочу сделать так, чтобы на 7950 поставить майнинг лайткоина, а на GTX 570 играть.

Подключаю монитор к GTX 570, запускаю последний cgminer и вижу такое:

 [2013-12-19 20:28:27] CL Platform 0 vendor: NVIDIA Corporation
 [2013-12-19 20:28:27] CL Platform 0 name: NVIDIA CUDA
 [2013-12-19 20:28:27] CL Platform 0 version: OpenCL 1.1 CUDA 6.0.1
 [2013-12-19 20:28:27] Platform 0 devices: 1
 [2013-12-19 20:28:27]  0       GeForce GTX 570
 [2013-12-19 20:28:27] CL Platform 1 vendor: Advanced Micro Devices, Inc.
 [2013-12-19 20:28:27] CL Platform 1 name: AMD Accelerated Parallel Processing
 [2013-12-19 20:28:27] CL Platform 1 version: OpenCL 1.2 AMD-APP (1268.1)
 [2013-12-19 20:28:27] Platform 1 devices: 1
 [2013-12-19 20:28:27]  0       Tahiti
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:28:27] ADL found less devices than opencl!
 [2013-12-19 20:28:27] There is possibly more than one display attached to a G
 [2013-12-19 20:28:27] Use the gpu map feature to reliably map OpenCL to ADL
 [2013-12-19 20:28:27] WARNING: Number of OpenCL and ADL devices did not match
 [2013-12-19 20:28:27] Hardware monitoring may NOT match up with devices!
 [2013-12-19 20:28:27] 1 GPU devices max detected
 [2013-12-19 20:28:27] USB all: found 8 devices - listing known devices

После этого начинается майнинг, но он загружает GTX 570

 

Пробовал поиграться с параметром --gpu-map, но ничего не помогло, т.к. из сообщения выше видно, что видяхи находятся на разных "платформах (platforms)".

 

Попробовал подключить к второй видяхе (HD7950) монитор, выдало следующее:

 [2013-12-19 20:31:33] CL Platform 0 vendor: NVIDIA Corporation
 [2013-12-19 20:31:33] CL Platform 0 name: NVIDIA CUDA
 [2013-12-19 20:31:33] CL Platform 0 version: OpenCL 1.1 CUDA 6.0.1
 [2013-12-19 20:31:33] Platform 0 devices: 1
 [2013-12-19 20:31:33]  0       GeForce GTX 570
 [2013-12-19 20:31:33] CL Platform 1 vendor: Advanced Micro Devices, Inc.
 [2013-12-19 20:31:33] CL Platform 1 name: AMD Accelerated Parallel Processing
 [2013-12-19 20:31:33] CL Platform 1 version: OpenCL 1.2 AMD-APP (1268.1)
 [2013-12-19 20:31:33] Platform 1 devices: 1
 [2013-12-19 20:31:33]  0       Tahiti
 [2013-12-19 20:31:33] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:31:33] Failed to ADL_Adapter_ID_Get. Error -1
 [2013-12-19 20:31:33] GPU 0 AMD Radeon HD 7900 Series hardware monitoring enabl
ed
 [2013-12-19 20:31:33] 1 GPU devices max detected
 [2013-12-19 20:31:33] USB all: found 8 devices - listing known devices
 [2013-12-19 20:31:33] No known USB devices

И опять стал майнить на GTX 570.

 

Как сделать так, чтобы он майнил на 7950, а GTX570 просто была подключена к монитору и использовалась для игр?

 

PS. если в системе оставить только 7950, то майнит норм.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Курите параметры -platform и -device
Обе одновременно майнить не могут. Надо просто указать параметры запуска для атишки

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Lexis77,пробовал

--gpu-platform 1

cgminer просто вылетает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Значит просто device указать. Инструкцию же никто не прячет.

 

А ати точно платформ 1 ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Lexis77,ну, судя по тому, что написала программа, то платформ 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Странно. Когда я пускал 3 ати и одну GTX560, у меня наоборот, именно нвидия не работала

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Lexis77,ну, судя по тому, что написала программа, то платформ 1

"gpu-platform": "1",

"device" : "0",

 

У меня на машине 7870 стоит, майнит, а сам комп на встроенной hd4000. В 7870 вставлена заглушка и разгон памяти через Afterburner

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
(изменено)

Все, ребята, тупанул я конкретно =) Завелась с такими параметрами:

-I 19 --gpu-powertune -10 --gpu-platform 1 -d 0

Однако вот что странно: моник подключен к GTX 570, майнится на 7950, а все равно лагает сильно комп.

Изменено пользователем demon_17

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пробовал такой вариант:

--gpu-platform 1 -d 0

Все равно запускается GTX 570. Прям мистика какая-то. А заглушку обязательно использовать?

Без заглушки скорость майнинга 0 кх вроде было

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@pendalf2008, см выше, проблему решил уже (кроме лагов)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@demon_17, смотри процессы, из-за кого лагает
если цгминер, тонадо памятью править

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@pendalf2008, см выше, проблему решил уже (кроме лагов)

Ок, не обновил перед ответом. А насчет лагов - у меня тоже лагает, если Gpu-z запущен. без него вроде норм работает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Из-за чего может лагать, если майнится на 7950, а моник подрублен к GTX570? Загрузка ЦП 20%.

Еще вопрос: без заглушки в 7950 можно как-нибудь мониторить температуру и скорость кулера? Или, скажем, один раз подрубить 7950 к монитору, настроить все параметры, чтобы автоматически регулировался кулер, а потом подключить монитор к 570 и не использовать заглушку на 7950?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Заглшка не всегда нужна.Если без нее не работает, то это другой вопрос.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня почти так же, только первую платформу майнер не видит.

 

Можно как нибудь в такой ситуации управлять кулером?

Две карты: встроенная - Nvidia и вторая - MSI R9270

 
Microsoft Windows [Version 6.1.7601]
© Корпорация Майкрософт (Microsoft Corp.), 2009. Все права защищены.
 
C:\Users\Admin>cd c:\Бит\cgminer-3.2.2-windows\
 
c:\Бит\cgminer-3.2.2-windows>cgminer.exe -n
 [2014-01-25 15:25:36] CL Platform 0 vendor: Intel® Corporation
 
 [2014-01-25 15:25:36] CL Platform 0 name: Intel® OpenCL
 [2014-01-25 15:25:36] CL Platform 0 version: OpenCL 1.1
 [2014-01-25 15:25:36] Error -1: Getting Device IDs (num)
 [2014-01-25 15:25:36] CL Platform 1 vendor: Advanced Micro Devices, Inc.
 
 [2014-01-25 15:25:36] CL Platform 1 name: AMD Accelerated Parallel Processing
 
 [2014-01-25 15:25:36] CL Platform 1 version: OpenCL 1.2 AMD-APP (1348.5)
 
 [2014-01-25 15:25:36] Platform 1 devices: 1
 [2014-01-25 15:25:36]  0       Pitcairn
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] Failed to ADL_Adapter_ID_Get. Error -1
 
 [2014-01-25 15:25:36] ADL found less devices than opencl!
 [2014-01-25 15:25:36] There is possibly more than one display attached to a GPU
 
 [2014-01-25 15:25:36] Use the gpu map feature to reliably map OpenCL to ADL
 
 [2014-01-25 15:25:36] WARNING: Number of OpenCL and ADL devices did not match!
 
 [2014-01-25 15:25:36] Hardware monitoring may NOT match up with devices!
 
 [2014-01-25 15:25:36] 1 GPU devices max detected
 [2014-01-25 15:25:37] USB all: found 4 devices - listing known devices
 
 [2014-01-25 15:25:37] No known USB devices
 
c:\Бит\cgminer-3.2.2-windows>
 
Майнит вторая карта, а первая - для монитора, но нет управления и не выводит температуру
 

sgminer version 4.0.0 - Started: [2014-01-25 15:17:19]
---------------------------------------------------------------------------
(5s):411.1K (avg):402.7Kh/s | A:4203  R:0  HW:0  WU:356.3/m
ST: 2  SS: 0  NB: 6  LW: 69  GF: 2  RF: 0
Connected to ru-1.litecoinpool.ru diff 64 with stratum as user kazbek2005.k
Block: 2c67d783...  Diff:205M  Started: [15:28:23]  Best share: 5.72K
---------------------------------------------------------------------------
[P]ool management [G]PU management ettings [D]isplay options [Q]uit
 GPU 0:                | 404.0K/402.7Kh/s | R:  0.0% HW:0 WU:356.3/m I:20
 
 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ладно, не парьтесь. Подключил вентиляторы на прямую от  CPU FAN - пусть молотят на 100 % мощности. консервативный подход, так сказать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×