Jump to content
boriskae

Крашатся все opencl майнеры

Recommended Posts

Система windows 8 х32, видеокарта HD6850, драйверы и sdk последние. Проблема заключается в том, что после запуска любого opencl майнера вылетает окно windows о завершении работы программы. Единственный майнер, который получается запустить, это cgminer версии 2,10,3, но там вылетает ошибка "GPU0: invalid nonce - HW error" вот весь лог:

 


 

 cgminer version 2.10.3 - Started: [2013-05-02 16:45:28]
--------------------------------------------------------------------------------
 (5s):194.6M (avg):193.1Mh/s | Q:11  A:0  R:0  HW:5  E:0%  U:0.0/m
 ST: 2  SS: 0  DW: 22  NB: 1  LW: 37  GF: 0  RF: 0  WU: 4.3
 Connected to pool.50btc.com diff 1 with stratum as user *****@***.com
 Block: 00785413ecebbc0a...  Diff:10.1M  Started: [16:45:28]  Best share: 0
--------------------------------------------------------------------------------
 [P]ool management [G]PU management ettings [D]isplay options [Q]uit
 GPU 0:  74.0C  67%    | 194.0M/193.1Mh/s | A:0 R:0 HW:5 U:0.00/m I: 4
--------------------------------------------------------------------------------
 
 [2013-05-02 16:45:27] Started cgminer 2.10.3
 [2013-05-02 16:45:27] Probing for an alive pool
 [2013-05-02 16:45:28] Switching pool 0 http://pool.50btc.com:8332 to stratum+tc
p://pool.50btc.com:3333
 [2013-05-02 16:45:28] Disabling extra threads due to dynamic mode.
 [2013-05-02 16:45:28] Tune dynamic intensity with --gpu-dyninterval
 [2013-05-02 16:45:29] Thread 1 being disabled
 [2013-05-02 16:45:39] GPU0: invalid nonce - HW error
 [2013-05-02 16:45:45] GPU0: invalid nonce - HW error
 [2013-05-02 16:46:01] GPU0: invalid nonce - HW error
 [2013-05-02 16:46:09] GPU0: invalid nonce - HW error
 [2013-05-02 16:46:27] GPU0: invalid nonce - HW error

 

Вопрос:в чём проблема?

Edited by boriskae

Share this post


Link to post
Share on other sites

Карта новая? Если б\у, то возможно карточка уже хорошенько изнасилованная.

Share this post


Link to post
Share on other sites

Удалите все драйвера: http://www2.ati.com/drivers/amd_cleanup_util_1.2.1.0.exe + (перезагрузка)

Установите только Catalyst Software Suite 13.4: http://www2.ati.com/drivers/13-4_vista_win7_win8_64_dd_ccc_whql.exe + (перезагрузка)

Попробуйте новую версию cgminer 3.1.0: http://ck.kolivas.org/apps/cgminer или http://rusfolder.com/36245121

 

Распакуйте на диск С: в корень. Киньте ярлык на рабочий стол. В свойствах ярлыка пропишите:
Объект:

C:\cgminer-3.1.0-windows\cgminer.exe -o http://50btc.com:3333 -u логин -p пароль

 

Если заработает по дефолту, то добавьте в конце: -I 9

Edited by DigitalMan

Share this post


Link to post
Share on other sites

Удалите все драйвера: http://www2.ati.com/drivers/amd_cleanup_util_1.2.1.0.exe + (перезагрузка)

Установите только Catalyst Software Suite 13.4: http://www2.ati.com/drivers/13-4_vista_win7_win8_64_dd_ccc_whql.exe + (перезагрузка)

Попробуйте новую версию cgminer 3.1.0: http://ck.kolivas.org/apps/cgminer или http://rusfolder.com/36245121

 

Распакуйте на диск С: в корень. Киньте ярлык на рабочий стол. В свойствах ярлыка пропишите:

Объект:

C:\cgminer-3.1.0-windows\cgminer.exe -o http://50btc.com:3333 -u логин -p пароль

 

Если заработает по дефолту, то добавьте в конце: -I 9

Всё сделал по Вашей инструкции (только драйвера поставил для 32 битной системы). Проблема осталась, последняя версия cgminer крашится (вылетает сообщение windows). А как видеокарту можно проверить на "битость"? Карте год, под нагрузкой была не очень много (прошёл на ней мафию вторую, l.a. noire и ассасин криид), в играх не сбоит и артефактов не замечал.

Edited by boriskae

Share this post


Link to post
Share on other sites

@boriskae, каким образом эта видяха оказалась в системе под Вин8, да еще и х32? Сами экспериментируете?

Share this post


Link to post
Share on other sites

@boriskae, каким образом эта видяха оказалась в системе под Вин8, да еще и х32? Сами экспериментируете?

Перешел с вин 7 на вин 8. Оперативы 4 гб, поэтому не вижу смысла ставить х64. Хочу попробовать поставить другую ос на второй винт для проверки, что рекомендуете?

Share this post


Link to post
Share on other sites

Можно попробовать поставить недостающие драйвера программой Slimdrivers : http://www.driverupdate.net/

 

Если не поможет, переставить в другой комп, установить драйвера. Не заработает майнинг - тогда "абзац".

 

Если заработает, тогда разобрать свой комп, продуть воздушным компрессором, перевтыкать все кабели и платы заново, обновить биос, поставить Winx64 (если проц. поддерживает), поставить все обновления Win, поставить все драйвера на всё железо, добавить свежие драйвера Slimdriver-ом. обновить DirectX (через web setup). И затем поставить майнеры. (долго, но оно этого стоит).

 

P.S. Если проц. просит Winx64 ему надо её дать :)

Share this post


Link to post
Share on other sites

 Проблема осталась, последняя версия cgminer крашится (вылетает сообщение windows)

 

я тут борюсь с этой прогой

https://forum.bits.media/index.php?/topic/239-cgminer/page-33

В ярлыке ставь эмуляцию ВИН-ХР . Прога запустится но будет ошибка. Уже полдела.

GPU: invalid nonce - HW error

 

другую ос на второй винт для проверки, что рекомендуете?

 

Убунту )) Но х32. Говорят стабильнее. 

Edited by iks

Share this post


Link to post
Share on other sites

с переходом на 13,4 тоже все крашилось, поставил дрова что были до этого и накатил ocl с этого сайта - все гуд

http://btcsec.com/programms/ocl2.5/ocl2.5.zip

Share this post


Link to post
Share on other sites

Положи то что по ссылке выше в каталог с майнером и так любой версии ocl кидай, без переустановки. Пробуй запускать с командой -D -T -n попутно смотри какая версия ocl отображается в майнере.

Share this post


Link to post
Share on other sites

Перешел с вин 7 на вин 8. Оперативы 4 гб, поэтому не вижу смысла ставить х64

У меня чуть мозг не взорвался... Где логика?

 

Как показывает практика, самые стабильные дрова 12.8 и 13.1

Share this post


Link to post
Share on other sites

Положи то что по ссылке выше в каталог с майнером и так любой версии ocl кидай, без переустановки. Пробуй запускать с командой -D -T -n попутно смотри какая версия ocl отображается в майнере.

Спасибо за совет! Провёл полную очистку от amd драйверов этой прогой http://www2.ati.com/drivers/amd_cleanup_util_1.2.1.0.exe , потом сверху накатил каталист 12,8, кинул в system32 файлы из этого архива http://btcsec.com/programms/ocl2.5/ocl2.5.zip Но майнер всё равно крашился. Помогло копирование dll из архива http://btcsec.com/programms/ocl2.5/ocl2.5.zip в папку с майнером.

Edited by boriskae

Share this post


Link to post
Share on other sites

 

в попку с майнером.

вот это очепятка )))

а вообще в папку с майнером их кидать не надо, они все-равно оттуда не работают. значит как-то некорректно кинул их в сис32.

Share this post


Link to post
Share on other sites

Положи то что по ссылке выше в каталог с майнером   

Зачем тогда советовать кидать в папку если они для систем32. Копирование с полной заменой. У меня тоже один работает второй не работает. Тот что в корне папка не работает не запускается ошибка та же  https://forum.bits.media/index.php?/topic/239-cgminer/?p=18956   тот что не в корне запукался. 

 

На линуксе интересно таких проблем нет?))

Edited by iks

Share this post


Link to post
Share on other sites

 

Перешел с вин 7 на вин 8. Оперативы 4 гб, поэтому не вижу смысла ставить х64

У меня чуть мозг не взорвался... Где логика?

 

Как показывает практика, самые стабильные дрова 12.8 и 13.1

А в чём Вы не видите логику? В переходе с вин 7 на вин 8, или в том, что на 4х гигах стоит х32? С вин 7 на вин 8 перешёл ради любопытства и привык к ней. Насчёт 4х гигов и х32 - не вижу смысла переходить на х64 ради 500 Мб оперативы. А 4 планки по гигабайту полностью реализуют двухканальный режим памяти.

 

 

в попку с майнером.

вот это очепятка )))

а вообще в папку с майнером их кидать не надо, они все-равно оттуда не работают. значит как-то некорректно кинул их в сис32.

Исправил :-[ Наверное да, некорректно кинул, но в ближайшее время не буду трогать, пока работает :)

Share this post


Link to post
Share on other sites

Была та же проблема(HD 6990) решилась с помощью удаления всех драйверов и установкой 12.8 .  Я ВАС ЛЮБЛЮ!!! запарился но нашел правильный ответ, 7 часов поиска не напрасны.

Edited by foggot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...