Перейти к публикации
Alex00000001

Почему вылетает CGminer в авалоне?

Рекомендованные сообщения

Доброго времени, подскажите пожалуйста что нужно сделать, включаю авалон-2 после простоя допустим, он работать может около часа, после чего зависает сгмайнер, тоесть все работает и все отзывается, но служба сгмайнера не считает, тоесть в статусе нет гигахэшей и на пул соответственно не идет ничего... после перезагрузки через панельку он перезапускается и работает снова, но уже меньше по времени, а после нескольких таких перезапусков, может работать пол часа, а может 5 минут... может кто знает как прописать отслеживание службы что бы он в реальном времени ее запускал без этих перезапусков? пока прописал в кроне вот такой костыль */25 *  *   *   *     /sbin/reboot , тоесть каждые 25 минут он сам перезагружается, но эта ерунда вообще не устраивает и скорость теряется на пуле аж на 25%.... помогите люди добрые :(

Спасибо заранее...

 

frmjpg_4539730_10808928.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А перед падением вот такие ошибки вываливаются в лог:

 

 

[  879.670000] usb 1-1: clear tt 1 (9031) error -71
[  879.680000] usb 1-1: clear tt 1 (8030) error -71
[  879.680000] usb 1-1: clear tt 1 (9031) error -71
[  879.700000] usb 1-1: clear tt 1 (9031) error -71
[  879.710000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.720000] usb 1-1: clear tt 1 (9031) error -71
[  879.720000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.730000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.740000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.750000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.750000] hub 1-1:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[  879.760000] hub 1-1:1.0: cannot disable port 1 (err = -71)
[  879.770000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.780000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.790000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.790000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.800000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.800000] hub 1-1:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[  879.820000] hub 1-1:1.0: cannot disable port 1 (err = -71)
[  879.820000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.830000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.840000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.850000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.860000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.860000] hub 1-1:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[  879.870000] hub 1-1:1.0: cannot disable port 1 (err = -71)
[  879.880000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.890000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.890000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.900000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.910000] hub 1-1:1.0: cannot reset port 1 (err = -71)
[  879.910000] hub 1-1:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
[  879.930000] hub 1-1:1.0: cannot disable port 1 (err = -71)
[  879.930000] hub 1-1:1.0: cannot disable port 1 (err = -71)
[  879.940000] hub 1-1:1.0: hub_port_status failed (err = -71)
Изменено пользователем Alex00000001

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так пишет же он:"Может у вас кабель хреновый?"

1.Попробуй другой порт и кабель

2.Сам Авалон(производственный брак вылазит с прогревом)попробуй его обдуть(проверить,изменится ли время)

3.По энергопотреблению хаб засыпать не может?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

он по сетевому кабелю подсоединен в роутер, а усб это внутри идет от его внутреннего роутера в мамку внутри авалона... с перегревом вроде нет проблем, температура в районе 50 градусов держится..

 

как понять "3.По энергопотреблению хаб засыпать не может?"

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тогда остается подкинуть другой роутер.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я вот думаю если бы дело было в кабеле или именно в роутере встроенном в асик, то при зависании меня бы не пускало в админскую панель и спокойно не давало перезагрузить асик удаленно... а значит можно предположить что вылетает служба майнера, так как перестает идти хэшрейт!


Тогда остается подкинуть другой роутер.

а каким образом я его прошью? он же управляет асиком....


еще есть вариант воткнуть усб который внутри идет в мамку, не в мамку, а сразу в комп, но попробовав раз так сделать асик не заводился даже после выключения блока питания, а только после обесточивания на 10 минут... как то не очень экспериментировать так на абум

Изменено пользователем Alex00000001

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А без его роутера он что не заводится?

Я так понял разговор про майнер со своим роутером и клиентом?

Извини,я не пользовался такими.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Роутер прошит своим биосом от авалона и управляет всем авалоном, т.е. что бы прошить такой же роутер или другой (так как такую же версию нет смысла, они все глючные эти версии роутеров), там нужно каждый файл заливать и прописывать. Если вы посмотрите внимательно на скрин, то в шапке в верхнем левом углу написано OpenWrt , а это и есть ничто иное как роутер.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×