Перейти к публикации
epros

Установка bitcoind на debian weezy

Рекомендованные сообщения

Я прочитал вот этот блог. Но, вероятно, за полтора года что-то изменилось, ибо сия инструкция мне не помогла. А именно: там сказано, что этот пакет зависит от libdb4.8-dev и libdb4.8++-dev, но таковые в репозиторий debian нынче не входят. Вместо них Berkeley DB поддерживается пакетами libdb5.1-dev и libdb5.1++-dev (причём от первого у меня зависит куча уже установленных пакетов). Но проблема в том, что вот здесь написано: "using these will break binary wallet compatibility". Так что же делать? Как заменить "непригодный" libdb5.1-dev на "пригодный" libdb4.8-dev, не обрушив при этом кучу уже установленного софта?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Откомпилировать вручную, установить в /usr/local/ или куда ещё понравится, отлинковать. Исходники найдёте у Оракла.

 

Также можно не париться и грохнуть старый кошель, предварительно вытряхнув из него все ключи, которые затем загнать в новый кошель. Весьма удобно перевести всё нажитое тяжким и непосильным трудом на один адрес, тогда процедура экспорта и импорта максимально упростится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×