Перейти к содержимому


Фотография

рестарт --> запуск cgminer --> зависание. Иногда...


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 10

#1 rldep

rldep

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 812 сообщений

Отправлено 25 April 2014 - 17:11

4 разномастных карты (6930,6950,6970,5850), мать ASRock FM2A55Pro+, Athlon X2 340.

Win7 x64, Catalyst 13.12, cgminer 3.7.2 (или vertminer 0.5.2 - неважно).

 

Все как обычно - cgminer в автозапуске через минуту после загрузки. Раз в 5 минут скрипт проверяет, не отвалилось ли что (карты-то разогнаны), и если что - рестарт (shutdown -r -t 5).

 

Но есть странность. ИНОГДА, после рестарта, cgminer работает секунд 10-15 (при этом на всех картах хэши считаются, шары отправляются), затем система виснет намертво, либо ребутится. Ребут может произойти несколько раз, и в итоге система все равно зависнет.

А если cgminer не запускать - не зависнет!!!

 

В какую сторону копать? Что может перекашиваться в системе так, что не сбрасывается при "теплом" рестарте, и проявляется только при запуске cgminer?


Сообщение отредактировал rldep: 25 April 2014 - 17:11

  • 0

#2 adv

adv

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 6803 сообщений
  • ГородВладивосток это +7 часов к Мск времени

Отправлено 25 April 2014 - 17:45

я бы посмотрел  для начала в сторону обеспечения питанием карт по мощности


  • 1

В наличии в России  iBeLink™ DM11G X11/Dash Miner 10.8 GH/s стоимость 1 100 000 руб    Antminer L3+, 504MH/s  350 тр      В ЛИЧКЕ НЕ ОБЩАЮСЬ .Все вопросы по efcwefc1@gmail.com+79I47О65652 (мтс). продажа оборудования:  https://forum.bits.media/index.php?/topic/3867-allrossiiabelaruskazakhstan-kompakt-gpu-mainer-vse/?p=72840


#3 rldep

rldep

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 812 сообщений

Отправлено 25 April 2014 - 23:14

adv,

 

первый БП - Inwin 600W (576 W по +12v) - питает 6950 (920 MHz) + 6930 (910 MHz) + система (проц, мать, винт, вентиляторы)

второй БП - OCZ 650W (552 W по +12v) - питает 6970 (970 MHz) + 5850 (910 MHz)


  • 0

#4 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7099 сообщений

Отправлено 25 April 2014 - 23:37

rldep, а без карты 5850 если попробовать запустить?


  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#5 alladin

alladin

    Новичок

  • Пользователи
  • Pip
  • 42 сообщений

Отправлено 26 April 2014 - 00:01

У меня так от разгона висло. Убрал разгон и все прошло.


  • 0

#6 rldep

rldep

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 812 сообщений

Отправлено 26 April 2014 - 20:50

rldep, а без карты 5850 если попробовать запустить?

 

Чем именно 5850 не угодила? :-) Если надо - попробую.

 

 

У меня так от разгона висло. Убрал разгон и все прошло.

 

Что, совсем убрать? Там у некоторых карт штатная частота 725... :-(((


Сообщение отредактировал rldep: 26 April 2014 - 20:51

  • 0

#7 Аукс

Аукс

    Пользователь

  • Пользователи
  • PipPip
  • 384 сообщений
  • ГородРФ

Отправлено 26 April 2014 - 21:11

rldep, напиши полную строку запуска (батник). У самого бывает такое редко, что если некорректно закрывается винда (где-то что-то пошло не так как хотелось бы :) ), то при ребуте иногда открываются окна цгмайнера но с какой-то ошибкой. В этом случае закрываю окна и перезапускаю заново и все, работает дальше ровно. Интересует твой скрипт - 

Раз в 5 минут скрипт проверяет, не отвалилось ли что

если не жалко поделись, скоро лето  :)
  • 0

Спасибо - это зеленая стрелка вверх, в правом нижнем углу.  :)

Пулы которым я доверяю и на которых копаю - NiceHash

 


#8 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7099 сообщений

Отправлено 26 April 2014 - 21:30

Чем именно 5850 не угодила?
да были тут темы...типа и дрова они свои любят.. не всегда новые..и еще что то.. старые карты то...
  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#9 rldep

rldep

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 812 сообщений

Отправлено 27 April 2014 - 20:36

Аукс, батник:

\cgm\cgminer372\cgminer.exe --scrypt -c ferma-one.conf --no-submit-stale --api-listen

 

конфиг:

{
(про пулы поскипано):
 
"gpu-vddc" : "1.175,1.175,1.1,1.088",
"gpu-engine" : "970,920,920,910",
"gpu-memclock" : "1375,1250,1000,1050",
"gpu-powertune" : "20,20,0,0",
 
"gpu-fan" : "50-100,50-100,50-100,50-100",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75,75,75,75",
 
"intensity" : "20,20,19,20",
"shaders" : "1564,1564,1280,1440",
"thread-concurrency" : "8128,8128,7680,8128",
"gpu-threads" : "1",
 
"auto-fan" : true,
"expiry" : "120",
"failover-only" : true,
"log" : "5",
"queue" : "4",
"scan-time" : "1",
"temp-hysteresis" : "3",
 
"kernel-path" : "/usr/local/bin"
}
карты 6970, 6950@6970, 6930, 5850
 
 
Lion74, понятно... можно попробовать убрать... но честно говоря, из все карт именно она отваливается наиболее корректно: становится SICK, и cgminer спокойно работает дальше без нее. А вот когда в SICK валится, к примеру, 6930 - майнер успевает сообщить в лог, что она SICK, и закрывается :-)
 
Скрипт вот из этой темы: 

  • 0

#10 temrus63

temrus63

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 1847 сообщений

Отправлено 27 April 2014 - 21:12

.


Сообщение отредактировал temrus63: 17 January 2017 - 17:14

  • 0

#11 rldep

rldep

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 812 сообщений

Отправлено 29 May 2014 - 12:11

Причина оказалась в карте 6950. Она и в другом компе ведет себя аналогично ))


  • 0




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных