Jump to content
Sign in to follow this  
kezavrik

Ошибка HW

Recommended Posts

Друзья, помогите, пожалуйста, уже намучился, никак не могу понять в чем проблема.

Имеется ферма из двух видеокарт AMD Radeon r9 280x (DC2T-3GD5), все работает нормально, но всегда на одной из двух видеокарт через какой-либо промежуток времени начинают вылазить HW от 1 до 4, причем вторая видюха нормально функционирует

 

вот конфиг 

 

cgminer --scrypt -w 256 --thread-concurrency 8192 --gpu-fan 100 --gpu-engine 1040 --gpu-memclock 1450 -d 0 -d 1 -g 2 --intensity 13 -o x -u x -p x

 

 

Раньше --thread-concurrency стояло 8191 при таком значении ошибки вылетали через 1-2 часа, менял на 8190 не помогло, поменял потом 8192 и радости моей не было предела, стабильно работала без ошибок часов 10-12, но потом с утра проснувшись, смотрю снова 2 ошибки. Оставил майниться лайты на койнотроне вообще за ночь набежало 5 ошибок

Но сегодня с утра, я конкретно оболдел, вылезло 19 ошибок, причем все на той же злополучной видеокарте.. Помогите пожалуйста.

 

PS одна карта выдает 720кхеш (которая работает нормально), а другая, у которой выскакивают ошибки чуть поменьше (710-715)

 

PPS значения --gpu-engine и memclock особо сильно изменениям не подвергались, небольшие изменения значений

Edited by kezavrik

Share this post


Link to post
Share on other sites

Рецепта нет,   смотреть надо индивидуально.

Попробуй например память до 1500 поднять, или вместо TC 8192 поставить shaders 2048

Share this post


Link to post
Share on other sites

Рецепта нет,   смотреть надо индивидуально.

Попробуй например память до 1500 поднять, или вместо TC 8192 поставить shaders 2048

 

Спасибо, поднял пока память, посмотрим.

А не может быть такое, что видеокарта слегка бракованная или может быть со слотом что-то? 

 

 

PS вылезла ошибка.. ставлю shaders...

upd с шейдерами на обоих по 150-200 ошибок

Edited by kezavrik

Share this post


Link to post
Share on other sites

у той которая сыпет ошибки ставь --thread-concurrency 10000 навскидку пока..и погляди

Share this post


Link to post
Share on other sites

у той которая сыпет ошибки ставь --thread-concurrency 10000 навскидку пока..и погляди

 

при запуске сразу выдает это

h_1393175051_3726474_5a731c60e3.png

если поставить thread-concurrency 819то получается то же самое

Edited by kezavrik

Share this post


Link to post
Share on other sites

setx GPU_MAX_ALLOC_PERCENT 100

setx GPU_USE_SYNC_OBJECTS 1

Edited by poiuty

Share this post


Link to post
Share on other sites

у той которая сыпет ошибки ставь --thread-concurrency 10000 навскидку пока..и погляди

 

 

setx GPU_MAX_ALLOC_PERCENT 100

setx GPU_USE_SYNC_OBJECTS 1

 

поставил, cgminer запустился нормально, будем посмотреть. спасибо

Edited by kezavrik

Share this post


Link to post
Share on other sites

у той которая сыпет ошибки ставь --thread-concurrency 10000 навскидку пока..и погляди

 

не помогло, ошибка вылетела где-то через час

 

ради интереса поставил t-c 0, и cgminer в бине показал значение "22400", но при этом одна видеокарта работает как обычно, а у другой (проблемной) скорость 20-30 кх/c (!!!), это что за прикол такой

 

на ночь сегодня поставил со значением t-c 15k так 10 ошибок выдало за 7 часов

 

ps может быть майнер староват 3.5.0? Я ведь брал карты 2 недели назад и мой друг, который их брал 15 декабря, говорит, что у меня типа новое поколение и тд тп (они реально различались по внешнему виду)

Edited by kezavrik

Share this post


Link to post
Share on other sites

HW обычно из-за переразгона вылазят. Уменьшай частоту ядра постепенно (по 10 мгц) пока не перестанут появляться. И ещё t-c лучше ставить 8191 для этих карт

Share this post


Link to post
Share on other sites

HW обычно из-за переразгона вылазят. Уменьшай частоту ядра постепенно (по 10 мгц) пока не перестанут появляться. И ещё t-c лучше ставить 8191 для этих карт

 

хорошо, будем пробовать

насчет t-c не знаю, после того как я поставил 8192 (до темы на форуме) ошибки стали появляться позже с 8191 уже через полчаса были, а с 8192 через час-полтора-два

Share this post


Link to post
Share on other sites

В общем изменял настройки ошибки все равно вылетают, вот самые лучшие результаты:

 

 

733-734 - скорость на 1-ой карте - 0 HW
705-706 - 2-ая - 2 HW за 11 часов
--thread-concurrency 8192,8192 --gpu-engine 1060,1030 --gpu-memclock 1500,1450
 
732 - 0 HW
708 - 1 HW через 7 часов 
--thread-concurrency 8192,8191 -gpu-engine 1060,1030 --gpu-memclock 1500,1500

 

 

PS на первой карте ошибки вообще не вылетают

PPS дрова 13.12, win7 x64, мать ASUS Z87-A, оперативки 8 гигов

Edited by kezavrik

Share this post


Link to post
Share on other sites

@kezavrik, напругу чуть добавь на вторую карту..

Share this post


Link to post
Share on other sites

@kezavrik, напругу чуть добавь на вторую карту..

 

извините за глупый вопрос, но под напругой имеется ввиду t-c? если да, то я ставил 11200 и ошибки начинали вылетать через 3-4 часа уже

Share this post


Link to post
Share on other sites

У меня 4 таких карты, майнят 760 каждая попробуй как у меня --thread-concurrency 8192 --gpu-engine 1090,1090 --gpu-memclock 1500,1500

Share this post


Link to post
Share on other sites

У меня 4 таких карты, майнят 760 каждая попробуй как у меня --thread-concurrency 8192 --gpu-engine 1090,1090 --gpu-memclock 1500,1500

 

GPU-Z показывает что у меня GPU Clock 1070, даже не знаю стоит ли ставить.. при том, чем больше gpu-engine у меня, тем быстрее вылетают ошибки

ладно.. попробую)

Share this post


Link to post
Share on other sites

@kezavrik, напряжение на вторую карту имеется ввиду..на 0.01-0.02в

Share this post


Link to post
Share on other sites

мое наблюдение по поводу HW, может будет полезно. 

прикупилась лишняя видюха, в ферме места не было, пришлось собрать под нее побыстрому говнокомп из первого попавшегося бэу железа(его у меня достаточно). 

Так вот, на говно железе при -i 20 на видюхе полезли HW. исчезали только при -i14. ну ведь так не годится. и давай я мучать и тренд-конкуренцию и разгоны и павер тюны, пофигу. Подумал а не в железе ли дело, сунул карту в ферму-ошибок нет.

понеслась -блоки питания ставил разные от 450ватт), в итоге поцепил 850ватт с фермы, -пофик, память разную, процы,  пофик - тоесть проблема в мамке, т.к итоге подобрал говномать и семпрон 8 милетней давности на плате наибюджетнейшой того времени MSI, и 550ватном бэу бп инвин ) и все пошло без HW. карты выдает без ошибок свои положенные кхэши.

 

к чему я все это, многие пишут, что если видюха дает HW, значит или переразгон или видюхе хана. можно бится с этим долго, и видюху идти сдавать в магазин, но вот вам третий вариант - мать говно\не подходит для майна. размышляйте

Edited by dragodsm

Share this post


Link to post
Share on other sites

мое наблюдение по поводу HW, может будет полезно. 

прикупилась лишняя видюха, в ферме места не было, пришлось собрать под нее побыстрому говнокомп из первого попавшегося бэу железа(его у меня достаточно). 

Так вот, на говно железе при -i 20 на видюхе полезли HW. исчезали только при -i14. ну ведь так не годится. и давай я мучать и тренд-конкуренцию и разгоны и павер тюны, пофигу. Подумал а не в железе ли дело, сунул карту в ферму-ошибок нет.

понеслась -блоки питания ставил разные от 450ватт), в итоге поцепил 850ватт с фермы, -пофик, память разную, процы,  пофик - тоесть проблема в мамке, т.к итоге подобрал говномать и семпрон 8 милетней давности на плате наибюджетнейшой того времени MSI, и 550ватном бэу бп инвин ) и все пошло без HW. карты выдает без ошибок свои положенные кхэши.

 

к чему я все это, многие пишут, что если видюха дает HW, значит или переразгон или видюхе хана. можно бится с этим долго, и видюху идти сдавать в магазин, но вот вам третий вариант - мать говно\не подходит для майна. размышляйте

 

спасибо за ответ, уже давно пришел к выводу (да и владельцев крупных ферм также было), что ошибки сыпятся из-за слота PCI-E x16 3.0

и дело правда не в разгоне, у меня видюшка, которая стоит в слоте x2 пашет разогнанная на макс без ошибок вообще. ради интереса также разогнал свою проблемную, так она через 10 минут в SICK ушла и даже на частотах НИЖЕ стандартных все равно идут ошибки, а в другой слот вставить пока нет возможности

 

 

@kezavrik, напряжение на вторую карту имеется ввиду..на 0.01-0.02в

 

 

увеличение и уменьшение не помогло(

Edited by kezavrik

Share this post


Link to post
Share on other sites

@kezavrik, может в Биос-е матери поковыряться... перевести все PCIE в режим 1х? или что нить подобное...

Share this post


Link to post
Share on other sites

@kezavrik, может в Биос-е матери поковыряться... перевести все PCIE в режим 1х? или что нить подобное...

 

а разве можно так сделать? в биос пока не залазил, но смотрел обзоры не нашел в них ничего похожего на это

Share this post


Link to post
Share on other sites

а можно ли сделать так, чтобы в лог писалось, когда появилась ошибка и причина ее?

 

в cgminer добавил 

2>%time:~0,2%-%time:~3,2%_%DATE:/=%.log

 

 

но в логе все тоже самое что и в майнере

Share this post


Link to post
Share on other sites
 

@kezavrik, может в Биос-е матери поковыряться... перевести все PCIE в режим 1х? или что нить подобное...

 

Единственное, что нашел в биосе связанное с PCI-E это скорость, есть 3 выбора: auto, gen1, gen2. Выбирал и gen1 и gen2. Не помогло, буду наверное ставить более новый биос

Share this post


Link to post
Share on other sites

@kezavrik,кстати до сих пор балуюсь с настройками карт..замечено следующее.. на 7870 если в один поток и ставить TC от 8193 до примерно 11000...тоже вылазят ошибки.. Делаю больше 13000 ошибок нет. В двухпоточном режиме на 8193 нормально работает..

Share this post


Link to post
Share on other sites

@Lion74, так я уже какой только tc не перепробовал, все равно летят ошибки

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...