Перейти к содержимому

YoBit.Net

Фотография

Запуск CGminer до входа пользователя в Win7

cgminer

  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1 MAMMOHT

MAMMOHT

    Пользователь

  • Пользователи
  • PipPip
  • 66 сообщений

Отправлено 16 February 2014 - 11:53

Задача такая:

1. Есть небольшой парк компов с ATI видюхами на работе;

2. При загрузке эти компы требую входа под логином;

3. Логин там всего один и мне известен (т.к. сам всё устанавливал);

Вопрос: Как правильно прописать cgminer, чтобы он корректно запускался?

 

P.S. Почему я задаю такой вопрос:

Делаю батник типа:

c:\1\cg\cgminer.exe --scrypt -D -w 256 -I 19 -o stratum+tcp://wwww:3333 -u xxx.zzz -p xxx 2>c:\1\cg\logfile.txt 

при ручном запуске "вживую" на рабочем месте или через тимвьювер всё отлично HW=0, а при прописывании в автостарт компа запускается, жрёт ресурсы и в логах пишет типа:

 

 

 

 [2014-02-16 15:33:54] Global quota greatest common denominator set to 1
 [2014-02-16 15:33:54] Started cgminer 3.7.2
 [2014-02-16 15:33:57] CL Platform 0 vendor: Advanced Micro Devices, Inc.
 [2014-02-16 15:33:57] CL Platform 0 name: AMD Accelerated Parallel Processing
 [2014-02-16 15:33:57] CL Platform 0 version: OpenCL 1.2 AMD-APP (1348.5)
 [2014-02-16 15:33:57] Platform 0 devices: 1
 [2014-02-16 15:33:57] 0 Pitcairn
 [2014-02-16 15:33:57] Failed to ADL_Adapter_ID_Get. Error -5
 [2014-02-16 15:33:57] Failed to ADL_Adapter_ID_Get. Error -5
 [2014-02-16 15:33:57] Failed to ADL_Adapter_ID_Get. Error -5
 [2014-02-16 15:33:57] Failed to ADL_Adapter_ID_Get. Error -5
 [2014-02-16 15:33:57] Failed to ADL_Adapter_ID_Get. Error -5
 [2014-02-16 15:33:57] Failed to ADL_Adapter_ID_Get. Error -5
 [2014-02-16 15:33:57] ADL found less devices than opencl!
 [2014-02-16 15:33:57] There is possibly more than one display attached to a GPU
 [2014-02-16 15:33:57] Use the gpu map feature to reliably map OpenCL to ADL
 [2014-02-16 15:33:57] WARNING: Number of OpenCL and ADL devices did not match!
 [2014-02-16 15:33:57] Hardware monitoring may NOT match up with devices!
 [2014-02-16 15:33:57] Probing for an alive pool
 [2014-02-16 15:33:57] Popping work to stage thread
 [2014-02-16 15:33:57] Testing pool stratum+tcp://lxxxxxxxxxxx.ru:3333
 [2014-02-16 15:33:57] Succeeded delayed connect
 [2014-02-16 15:33:57] Failed to get sessionid in initiate_stratum
 [2014-02-16 15:33:57] Pool 0 difficulty changed to 16
 [2014-02-16 15:33:57] Stratum authorisation success for pool 0
 [2014-02-16 15:33:57] Pool 0 stratum+tcp://ччччччч:3333 alive
 [2014-02-16 15:33:58] Init GPU thread 0 GPU 0 virtual GPU 0
 [2014-02-16 15:33:58] CL Platform vendor: Advanced Micro Devices, Inc.
 [2014-02-16 15:33:58] CL Platform name: AMD Accelerated Parallel Processing
 [2014-02-16 15:33:58] CL Platform version: OpenCL 1.2 AMD-APP (1348.5)
 [2014-02-16 15:33:58] List of devices:
 [2014-02-16 15:33:58] 0 Pitcairn
 [2014-02-16 15:33:58] Selected 0: Pitcairn
 [2014-02-16 15:33:58] Preferred vector width reported 1
 [2014-02-16 15:33:58] Max work group size reported 256
 [2014-02-16 15:33:58] Max mem alloc size is 536870912
 [2014-02-16 15:33:58] Selecting scrypt kernel
 [2014-02-16 15:33:58] GPU 0: selecting lookup gap of 2
 [2014-02-16 15:33:58] GPU 0: selecting thread concurrency of 4032
 [2014-02-16 15:33:58] Loaded binary image scrypt130511Pitcairnglg2tc4032w256l4.bin
 [2014-02-16 15:33:58] Initialising kernel scrypt130511.cl with bitalign, 1 vectors and worksize 256
 [2014-02-16 15:33:58] Creating scrypt buffer sized 264241152
 [2014-02-16 15:33:58] initCl() finished. Found Pitcairn
 [2014-02-16 15:33:58] Pushing sem post to thread 0
 [2014-02-16 15:33:58] 1 gpu miner threads started
 [2014-02-16 15:33:58] API not running - API [2014-02- will not be available16 15:33:58] Work update message received
 
 [2014-02-16 15:33:58] Selecting pool 0 for work
 [2014-02-16 15:33:58] Generated stratum merkle 04d2407f659ad3527aa79dcd57db24b6060482a2b9db8e8a40cbbaca489b9d55
 [2014-02-16 15:33:58] Generated stratum header 00000002b6c2a1bf16b15667606f6e3db1ff097d7d2b0b48edcd339ab83a10f2e61586f004d2407f659ad3527aa79dcd57db24b6060482a2b9db8e8a40cbbaca489b9d55530077dc1b185c89000000000000008000000000000000000000000000000000000000000000000000000000000000
 [2014-02-16 15:33:58] Work job_id 396 nonce2 0 ntime 530077dc
 [2014-02-16 15:33:58] Generated target 000000000000000000000000000000000000000000000000000000f0ff0f0000
 [2014-02-16 15:33:58] Generated stratum work
 [2014-02-16 15:33:58] Pushing work from pool 0 to hash queue
 [2014-02-16 15:33:58] Network diff set to 2.69K
 [2014-02-16 15:33:58] New block: e61586f0b83a10f2edcd339a7d2b0b48b1ff097d606f6e3d16b15667b6c2a1bf... diff 2.69K
 [2014-02-16 15:33:58] Selecting pool 0 for work
 [2014-02-16 15:33:58] Generated stratum merkle f19a8e0459defce4d4b5b23e6c7fd29e2b0c532bb02bb5de1db683ec70a52bec
 [2014-02-16 15:33:58] Generated stratum header 00000002b6c2a1bf16b15667606f6e3db1ff097d7d2b0b48edcd339ab83a10f2e61586f0f19a8e0459defce4d4b5b23e6c7fd29e2b0c532bb02bb5de1db683ec70a52bec530077dc1b185c89000000000000008000000000000000000000000000000000000000000000000000000000000000
 [2014-02-16 15:33:58] Work job_id 396 nonce2 1 ntime 530077dc
 [2014-02-16 15:33:58] Waiting on sem in miner thread
 [2014-02-16 15:33:58] Generated target 000000000000000000000000000000000000000000000000000000f0ff0f0000
 [2014-02-16 15:33:58] Popping work from get queue to get work
 [2014-02-16 15:33:58] Generated stratum work
 [2014-02-16 15:33:58] Got work from get q [2014-02-16 15:33:58] ueue to get work for thread 0Pushing work from pool 0 to hash queue
 
 [2014-02-16 15:33:58] Selecting pool 0 for work
 [2014-02-16 15:33:58] Generated target 00000000000000000000000000000000000000000000000000000000ffff0000
 [2014-02-16 15:33:58] Generated stratum merkle 02520878cdf15eca10d53bb22d8295511cbd833d7b0f07de24f4656b5df016cf
 [2014-02-16 15:33:58] Generated stratum header 00000002b6c2a1bf16b15667606f6e3db1ff097d7d2b0b48edcd339ab83a10f2e61586f002520878cdf15eca10d53bb22d8295511cbd833d7b0f07de24f4656b5df016cf530077dc1b185c89000000000000008000000000000000000000000000000000000000000000000000000000000000
 [2014-02-16 15:33:58] Work job_id 396 nonce2 2 ntime 530077dc
 [2014-02-16 15:33:58] Generated target 000000000000000000000000000000000000000000000000000000f0ff0f0000
 [2014-02-16 15:33:58] Generated stratum work
 [2014-02-16 15:33:58] Pushing work from pool 0 to hash queue
 [2014-02-16 15:33:59] GPU 0 found something?
 [2014-02-16 15:33:59] [thread 0: 524288 hashes, 405.2 khash/sec]
 [2014-02-16 15:33:59] OCL NONCE 74854 found in slot 0
 [2014-02-16 15:33:59] GPU0: invalid nonce - HW error
 [2014-02-16 15:33:59] OCL NONCE 179939 found in slot 1
 [2014-02-16 15:33:59] GPU0: invalid nonce - HW error
 [2014-02-16 15:33:59] OCL NONCE 245983 found in slot 2
 [2014-02-16 15:33:59] GPU0: invalid nonce - HW error
 [2014-02-16 15:33:59] OCL NONCE 423514 found in slot 3
 [2014-02-16 15:33:59] GPU0: invalid nonce - HW error
 [2014-02-16 15:33:59] Discarded cloned or rolled work
 [2014-02-16 15:34:00] GPU 0 found something?
 [2014-02-16 15:34:00] [thread 0: 524288 hashes, 414.2 khash/sec]
 [2014-02-16 15:34:00] OCL NONCE 728051 found in slot 0
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 751801 found in slot 1
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 763413 found in slot 2
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 779390 found in slot 3
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 793860 found in slot 4
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 797216 found in slot 5
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 821428 found in slot 6
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 831660 found in slot 7
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 851307 found in slot 8
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 941202 found in slot 9
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 971248 found in slot 10
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 1026912 found in slot 11
 [2014-02-16 15:34:00] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:00] OCL NONCE 1047901 found in slot 12
 [2014-02-16 15:34:00] New best share: 1
 [2014-02-16 15:34:00]  Proof: 0000dd08053004e0845d146140b20ea4b2063eea7d40468f53e5b454c0dabd37
Target: 00000ffff0000000000000000000000000000000000000000000000000000000
TrgVal? no (false positive; hash > target)
 [2014-02-16 15:34:00] Share above target
 [2014-02-16 15:34:00] Discarded cloned or rolled work
 [2014-02-16 15:34:02] GPU 0 found something?
 [2014-02-16 15:34:02] [thread 0: 524288 hashes, 306.8 khash/sec]
 [2014-02-16 15:34:02] OCL NONCE 1072755 found in slot 0
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1089609 found in slot 1
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1204421 found in slot 2
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1206621 found in slot 3
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1205215 found in slot 4
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1292829 found in slot 5
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1316979 found in slot 6
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] OCL NONCE 1460829 found in slot 7
 [2014-02-16 15:34:02] GPU0: invalid nonce - HW error
 [2014-02-16 15:34:02] Discarded cloned or rolled work
 [2014-02-16 15:34:03] GPU 0 found something?
 [2014-02-16 15:34:03] [thread 0: 524288 hashes, 419.5 khash/sec]

 

 

 и на пуле мёртво всё (показывает не больше 20К вместо 400):

 

 

ребят, ПОМОГИТЕ плиз)))))


Сообщение отредактировал MAMMOHT: 16 February 2014 - 11:54

  • 0

#2 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7100 сообщений

Отправлено 16 February 2014 - 18:39

D -w 256 -I 19
это вобще зачем? чтоб тихо мирно трудились компы в батнике оставить только интенсивность 12, остальное по умолчанию.. и пусть молотят.. 
  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#3 Pingui

Pingui

    Неизлечимый перфекционист

  • Пользователи
  • PipPipPip
  • 950 сообщений

Отправлено 18 February 2014 - 04:57

Сталкивался с тем, что в винде можно работать с видяхами только из под активного сеанса пользователя. При запуске в фоне майнер сообщает, что карт-то и нету) Подобное поведение при подключении через rdp.


  • 0

#4 YaMaTo

YaMaTo

    Пользователь

  • Пользователи
  • PipPip
  • 128 сообщений
  • ГородКрасноярск

Отправлено 18 February 2014 - 05:33

Сталкивался с тем, что в винде можно работать с видяхами только из под активного сеанса пользователя. При запуске в фоне майнер сообщает, что карт-то и нету) Подобное поведение при подключении через rdp.

Другими словами, майнер стартует ещё до загрузки, необходимых ему, системных компонентов. Можно попробовать сделать задержку автостарта майнера на 30-60 сек.


Сообщение отредактировал YaMaTo: 18 February 2014 - 05:38

  • 0

#5 BearA

BearA

    Продвинутый пользователь

  • Bits.media Team
  • PipPipPip
  • 665 сообщений
  • ГородКрасноярск

Отправлено 18 February 2014 - 07:10

Сталкивался с тем, что в винде можно работать с видяхами только из под активного сеанса пользователя. При запуске в фоне майнер сообщает, что карт-то и нету) Подобное поведение при подключении через rdp.

Хм, я вот с таким не сталкивался.

При подключении через RDP майнер прекрасно видит карты, но не может читать их датчики.

В итоге карты видны, майнинг идет, а вот температуры на картах не видно, и частотами ядра и памяти невозможно управлять.

По идее то же самое должно быть и при запуске в фоне.

 

Хотя тут еще есть один момент - встроенное видео, бывает при запуске по рдп, или запуске в фоне майнер меняет их нумерацию.

В общем если не видит карт, то есть смысл поиграться с параметром --platform

Ноль или единица.


Platform 0

На компах еще и встроенный видеоадаптер есть?

 Параметр -p 1 добавь в батник.


  • 0

#6 Pingui

Pingui

    Неизлечимый перфекционист

  • Пользователи
  • PipPipPip
  • 950 сообщений

Отправлено 19 February 2014 - 04:20

 

Сталкивался с тем, что в винде можно работать с видяхами только из под активного сеанса пользователя. При запуске в фоне майнер сообщает, что карт-то и нету) Подобное поведение при подключении через rdp.

Другими словами, майнер стартует ещё до загрузки, необходимых ему, системных компонентов. Можно попробовать сделать задержку автостарта майнера на 30-60 сек.

 

Или необходимые ему компоненты не стартуют вовсе)

 

Хм, я вот с таким не сталкивался. При подключении через RDP майнер прекрасно видит карты, но не может читать их датчики.

Ну, может, есть зависимость от системы, карты и версии драйвера.
  • 0





Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных