Перейти к публикации
Exdeath

Майнинг на Ubuntu

Рекомендованные сообщения

(изменено)

Просто беда какая-то с Ubuntu 12.04...

На свежеустановленной системе и настроенной для майнинга в соответствии с этой или этой инструкцией абсолютно все майнеры выдают ошибку:

Segmentation fault (core dumped)

В то время, как на 11.10 всё отлично работает.

Подозреваю, что это связано с компиляцией pyopencl-0.92 на 12.04.

Поэтому после выхода 12.04 и её установки пришлось снова вернуться на 11.10.

Я бы пока пользовальзовался 11.10, благо до апреля 2013-го(окончания поддержки этого релиза) некоторое время ещё есть. Но как оказалось, это не вариант.

Дело в работе wi-fi адаптеров в качестве точки доступа, что называется из коробки. С этим всё в точности наоборот!

Я имею ввиду стандарный способ, предусмотренный разработчиками:

Network -> Wireless -> Use as Hotspot(или Сеть -> Беспроводное -> Использовать как точку подключения).

Пробовал два разных адаптера: этот и этот, на разном железе.

Результат всегда зависел исключительно от версии Убунты. На 12.04 оба адаптера работали на ура. Одним создавал точку доступа, другим подключался всегда без проблем. А в 11.10 стандартный способ не работает(через несколько секунд созданная точка доступа падает). Может быть это связано с тем, что в 12.04 ядро чуть поновее, я не знаю.

 

Кто-нибудь сталкивался с ошибкой Segmentation fault (core dumped) и/или знает как её исправить? Ведь 12.04 это релиз с долгосрочной поддержкой до апреля 2017-го, так обломно, что на нём что-то не работает, особенно такая важная вещь, как майнинг :'(

Изменено пользователем Exdeath

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я нашла на просторах биткоинтолка такую же проблему у человека. Цитирую его решение:

решение простое - удалите папку с SDK из /opt и установите APP-SDK-v2.7-lnx64. Подробнее можно прочитать здесь http://blog.markloiseau.com/2012/05/install-opencl-sdk-ubuntu/ или в README к SDK.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Огромное спасибо! Сейчас попробую.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

youtu.be/4SCrZ6bEqAc

Изменено пользователем Exdeath

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Только скорость намного меньше по сравнению с той, что была =( 388 против 418-ти при таком же разгоне.

P.S. А где эта тема? Я натыкался там через поиск на подобные проблемы в паре тем, но решения не видел(например здесь).

Изменено пользователем Exdeath

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ув. прошу помощи, не могу понять что со скоростью у второй подключенной карты

карты идентичны gv-795wf3-3gd 2rev bios FY+, по одной работают прекрасно, как в связке так у GPU 1 хэшрейт падает((

притом что загрузка максимальная

ubuntu 12.04.2 LTS, последние дрова с офф сайта, 4Gb ddr3

post-2102-0-44800400-1370517781_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×