Jump to content
Sign in to follow this  
Exdeath

Майнинг на Ubuntu

Recommended Posts

Просто беда какая-то с Ubuntu 12.04...

На свежеустановленной системе и настроенной для майнинга в соответствии с этой или этой инструкцией абсолютно все майнеры выдают ошибку:

Segmentation fault (core dumped)

В то время, как на 11.10 всё отлично работает.

Подозреваю, что это связано с компиляцией pyopencl-0.92 на 12.04.

Поэтому после выхода 12.04 и её установки пришлось снова вернуться на 11.10.

Я бы пока пользовальзовался 11.10, благо до апреля 2013-го(окончания поддержки этого релиза) некоторое время ещё есть. Но как оказалось, это не вариант.

Дело в работе wi-fi адаптеров в качестве точки доступа, что называется из коробки. С этим всё в точности наоборот!

Я имею ввиду стандарный способ, предусмотренный разработчиками:

Network -> Wireless -> Use as Hotspot(или Сеть -> Беспроводное -> Использовать как точку подключения).

Пробовал два разных адаптера: этот и этот, на разном железе.

Результат всегда зависел исключительно от версии Убунты. На 12.04 оба адаптера работали на ура. Одним создавал точку доступа, другим подключался всегда без проблем. А в 11.10 стандартный способ не работает(через несколько секунд созданная точка доступа падает). Может быть это связано с тем, что в 12.04 ядро чуть поновее, я не знаю.

 

Кто-нибудь сталкивался с ошибкой Segmentation fault (core dumped) и/или знает как её исправить? Ведь 12.04 это релиз с долгосрочной поддержкой до апреля 2017-го, так обломно, что на нём что-то не работает, особенно такая важная вещь, как майнинг :'(

Edited by Exdeath

Share this post


Link to post
Share on other sites

Я нашла на просторах биткоинтолка такую же проблему у человека. Цитирую его решение:

решение простое - удалите папку с SDK из /opt и установите APP-SDK-v2.7-lnx64. Подробнее можно прочитать здесь http://blog.markloiseau.com/2012/05/install-opencl-sdk-ubuntu/ или в README к SDK.

Share this post


Link to post
Share on other sites

Огромное спасибо! Сейчас попробую.

Share this post


Link to post
Share on other sites

youtu.be/4SCrZ6bEqAc

Edited by Exdeath

Share this post


Link to post
Share on other sites

Только скорость намного меньше по сравнению с той, что была =( 388 против 418-ти при таком же разгоне.

P.S. А где эта тема? Я натыкался там через поиск на подобные проблемы в паре тем, но решения не видел(например здесь).

Edited by Exdeath

Share this post


Link to post
Share on other sites

ув. прошу помощи, не могу понять что со скоростью у второй подключенной карты

карты идентичны gv-795wf3-3gd 2rev bios FY+, по одной работают прекрасно, как в связке так у GPU 1 хэшрейт падает((

притом что загрузка максимальная

ubuntu 12.04.2 LTS, последние дрова с офф сайта, 4Gb ddr3

post-2102-0-44800400-1370517781_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...