Перейти к содержимому
polym0rph

Библиотеки OCL

Рекомендуемые сообщения

Назначение: Майнинг

Скачать: Библиотеки OCL

Описание: Библиотеки OCL для улучшения быстродействия для драйверов AMD начиная с версии 11.12, проблема описана в F.A.Q по майнингу

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если бережёте трафик, то лучше скачать по этой ссылке (8,4 МБ)

Ссылка взята с форума bitcointalk.org из баттхёрт-топика про новый драйвер :-)

Так как майнить я начал сравнительно недавно, то про эту проблему и не подозревал. После даунгрейда AMD APP SDK до версии 2.5, со своих стандартных 237 МХ/с на видеокарте HD 6850@910, удалось выжать 244 МХ/с, что в принципе неплохо.

Использую CGMiner. Проверял также в Phoenix 1.7 - результат схожий.

 

Правда есть повод для беспокойства. С версией Каталиста 12.1 ушёл баг со 100% нагрузкой на одно ядро процессора в MultiGPU-конфигурации. Был ли это баг драйвера или AMD APP SDK - я не знаю. Поэтому советую сохранить файлы перед перезаписью. Мало ли... :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

заменил этими файлами старые (которые установились с драйвером) и исчезла поддержка opencl. Ни guiminer, ни 50miner не видят видеокарт. Причем на старом компьютере с такой же виндой (7) все отлично заменилось и скорость возросла. С чем это может быть связано?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
@Pashtet, а видеокарты какие? Эти библиотеки только для VLIW5 рекомендуются.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
(изменено)

5850, 6950(70), 7870

Изменено пользователем Pashtet

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

на 7870 работать не будут, на остальных должно быть все нормально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

5850, 6950(70), 7870

 

Надо в шапку добавить, что эти библиотеки только для 11 ветки драйверов.

 

Для 12 и выше все уже в комплекте и нормально работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
@kr1z1s, нет, по-крайней мере на 12.2 и на 12.8 нужно ставить эти библиотеки для VLIW5-видеокарт.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

драйвера 12.8. А как тогда видюхи загрузить на 98-99%. Раньше, без 7870, видеокарты грузились по максимуму, а сейчас (после установки 7870) иногда до 95% только доходит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@kr1z1s, нет, по-крайней мере на 12.2 и на 12.8 нужно ставить эти библиотеки для VLIW5-видеокарт.

 

Все равно надо шапку править, а то народ так и будет сносить дрова

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

kr1z1s все верно

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я правильно понял, что для 7970 не нужно заменять OCL-библиотеки на более старые? И разница по версии драйверов наблюдается или нет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×