Jump to content
Hlorofos

Ремонт Antminer S7, S9 (обмен опытом)

Hlorofos

Все полезные ссылки и FAQ можно найти в первом сообщении. Прежде чем задать вопрос, посмотрите там.

Message added by Hlorofos

Recommended Posts

 @profipcЯ заметил, что в таких логах, как например у @Flashikyo , там где показывает много не открывающихся ядер, и часто не читается температура идет таблица частот на этой плате с завышением относительно других плат в этом майнере. Странно, что бы 2 платы (нормально работающие) были на одну частоту, а именно сбойная на другую и всегда выше. На прошлой неделе общался с Челябинскими коллегами. Так вот у них на плате родной PIC был поменян на PIC, в котором были завышены частоты - лог совершенно такой-же как у пострадавших, куча не открывающихся ядер. Им нечем было шить память PIC и они махнули PIC еще раз, поставив, кажется, от L3+. В последнем не оказалось таблицы частот вообще, и контролька выставила частоту по дефолту 550 Мгц. И о чудо! все ядра открываются на 100%, только хэшрейт низкий. Это навивает на мысли, а не искажаются каим-либо образом данные в памяти PIC. Может какой-то баг в прошивке и контролька начинает в каком-то случае менять таблицу частот?

Есть какие либо мысли или практические данные по этому вопросу?

У кого есть подобные платы в ремонте, может попробуете понизить частоты в таблице в памяти PIC?

Share this post


Link to post
Share on other sites

Пересмотрел сейчас логи исправных майнеров. Так вот там даже на 14TH моделях частота не выше 662 Мгц. А у  @Flashikyo  и остальных со схожими симптомами аж 687 Мгц, при том, что на соседних платах у них 631 МГц и это явно не модели на 14TH. Это объясняет то, почему при конфигурировании ASIC'и отвечают (при старте они работают на какой-то низкой частоте и обмен по интерфейсу идет на скорости 115 200 б/c), а при шэшировании отваливаются и перестает считываться температура (частота из таблицы частот устанавливается непосредственно перед началом хэширования, скорость по интерфейсу выставляется 1 600 000 б/с, температура читается через 61-й ASIC).

Share this post


Link to post
Share on other sites
6 минут назад, Splinter сказал:

Пересмотрел сейчас логи исправных майнеров. Так вот там даже на 14TH моделях частота не выше 662 Мгц. А у  @Flashikyo  и остальных со схожими симптомами аж 687 Мгц, при том, что на соседних платах у них 631 МГц и это явно не модели на 14TH. Это объясняет то, почему при конфигурировании ASIC'и отвечают (при старте они работают на какой-то низкой частоте и обмен по интерфейсу идет на скорости 115 200 б/c), а при шэшировании отваливаются и перестает считываться температура (частота из таблицы частот устанавливается непосредственно перед началом хэширования, скорость по интерфейсу выставляется 1 600 000 б/с, температура читается через 61-й ASIC).

 

По симптомам у меня было так. Сначала упала температура на 15 градусов, хеш был в норме 4 500. Поработал так примерно 2 недели и после хеш упал до 1 000.

Share this post


Link to post
Share on other sites

@Flashikyo 15 градусов это дефолтная температура, не читается датчик температуры.

При скорости 4500 у вас получается модель на 13,5TH. Вы через скрытые меню в веб-интерфейсе частоты не меняли?

Share this post


Link to post
Share on other sites
1 минуту назад, Splinter сказал:

@Flashikyo 15 градусов это дефолтная температура, не читается датчик температуры.

При скорости 4500 у вас получается модель на 13,5TH. Вы через скрытые меню в веб-интерфейсе частоты не меняли?

Да у меня на 13.5. Но выдавал по факту 13.7. Частоты не менял.

Share this post


Link to post
Share on other sites

@Flashikyo Тогда попробуйте поменять частоту (естественно на меньше). Для вашей модели частота явно завышена. Ваша - 631 МГц. Правдо не уверен, что при наличии таблицы частот в памяти PIC, смена частоты в конфиге возымеет эффект.

Edited by Splinter

Share this post


Link to post
Share on other sites

А есть где нибудь инструкция как поменять частоты?

Share this post


Link to post
Share on other sites

@Flashikyo Не мучайтесь ставьте прошивку с фиксированной частотой 600. Тот же результат будет.

@Splinter Тоже заметил, что сбойные платы на прошивке с автовыбором частоты, чаще всего, легко начинают запускаться и работать на прошивке с фиксированной частотой. Симптомы с завышением частот наблюдаю - вы правы.

Edited by profipc

Share this post


Link to post
Share on other sites

@Splinter давайте попробуем изменить частоты у первой платы. Асик работает - цепляется минут  15. ошибок полно. Подскажите где у нас частоты - я с этим не разбирался.

 

myasic.txt

 

Share this post


Link to post
Share on other sites

Вот для 637 МГц

Скрытый текст

000F80    2350    0000    0000    000F    0030    0001    0011    0000
000F88    0010    0003    0011    0021    0000    0002    0021    0001
000F90    0012    0011    0011    0011    0010    0000    0020    0001
000F98    0001    0000    0010    0000    0012    0000    0000    0000
000FA0    007D    0048    0048    0448    0848    0048    0348    0348
000FA8    0348    0348    0348    0348    0348    0348    0348    0348
000FB0    0348    0348    0548    0748    2348    0048    0048    0048
000FB8    0048    0048    0048    0048    0048    0048    0048    0048
000FC0    0048    0048    0048    0048    0048    0048    0048    0048
000FC8    0048    0048    0048    0048    0048    0048    0048    0048
000FD0    0048    0048    0048    0048    0048    0048    0048    0048
000FD8    0048    0048    0048    0048    0048    0048    0048    0048
000FE0    3F5B    3E00    0000    0000    231C    3FFF    3FFF    3FFF
000FE8    3FFF    3FFF    3FFF    3FFF    3FFF    3FFF    3FFF    3FFF
000FF0    3F08    3F75    3F0A    3F18    3F57    3F3C    3FBC    3FB8
000FF8    3FD5    3F01    3F52    3F4B    3FFF    3FFF    3FFF    3FFF

 

Share this post


Link to post
Share on other sites

@Splinter я пробовал так делать и 43 также поставлял (не на этом на другом асике с проблемами) - я только почему то решил что это напряжения. Изменений не было. Повторю с утра.

Edited by profipc

Share this post


Link to post
Share on other sites

Я уже давал полную расшифровку, продублирую еще раз. Можете сами выбрать нужную частоту. Кроме частот на каждый чип, нужно так же не забыть сменить частоту в параметре base_freq_index. Смещения в квадратных скобках даны относительно адреса 0x0FA0 и исчисляются в байтах (а не в словах как в реальной памяти PIC). Таблица freq_index записана в десятичной сиcтеме, т.е. , например, частота 550 = 58 = 0x3A,  600 = 66 = 0x42.

Скрытый текст

 

PIC_FLASH_POINTER_FREQ_START_ADDRESS   0x0FA0
PIC_FLASH_POINTER_FREQ_END_ADDRESS     0x0fDF
[0] = freq_gap;
[1] = FREQ_MAGIC = 0x7D;
[2] = старшие 4 бита temp_offset; // temp offset is not used now, set 0
[4] = младшие 4 бита temp_offset;
[6] = старшие 4 бита base_freq_index;
[8] = младшие 4 бита base_freq_index;
[10] = chain_vol_added;
[12] = старшие 4 бита minerMAC[0];
[14] = младшие 4 бита minerMAC[0]);
[16] = старшие 4 бита minerMAC[1];
[18] = младшие 4 бита minerMAC[1]);
[20] = старшие 4 бита minerMAC[2];
[22] = младшие 4 бита minerMAC[2]);
[24] = старшие 4 бита minerMAC[3];
[26] = младшие 4 бита minerMAC[3]);
[28] = старшие 4 бита minerMAC[4];
[30] = младшие 4 бита minerMAC[4]);
[32] = старшие 4 бита minerMAC[5];
[34] = младшие 4 бита minerMAC[5]);
[36] = старшие 4 бита chain_vol_value/10;
[38] = младшие 4 бита chain_vol_value/10;
[40] = magic_number = 0x23;
неиспользуемые четные адреса должны быть равны 0
нечетные адреса = freq_index
freq_index = 
[00]  "100" "125" "150" "175" "200" "225" "250" "275" "300" "325"
[10]  "350" "375" "400" "404" "406" "408" "412" "416" "418" "420"
[20]  "425" "429" "431" "433" "437" "441" "443" "445" "450" "454"
[30]  "456" "458" "462" "466" "468" "470" "475" "479" "481" "483"
[40]  "487" "491" "493" "495" "500" "504" "506" "508" "512" "516"
[50]  "518" "520" "525" "529" "531" "533" "537" "543" "550" "556"
[60]  "562" "568" "575" "581" "587" "593" "600" "606" "612" "618"
[70]  "625" "631" "637" "643" "650" "656" "662" "668" "675" "681"
[80]  "687" "693" "700" "706" "712" "718" "725" "731" "737" "743"
[90]  "750" "756" "762" "768" "775" "781" "787" "793" "800" "825"
[100] "850" "875" "900" "925" "950" "975"

PIC_voltage = 1608.420446 - 170.423497*vol_value/100.0; // vol_value = 940 означает 9,4В
vol_value = ((1608.420446 - PIC_voltage) *100.0)/170.423497 отбрасывается дробная часть и обнуляется крайнее правое значение.

 


 

Share this post


Link to post
Share on other sites

Есть плата с9 которая переодически доводит до истерики.изначально видела 26 чипов либо показывала в интерфейсе все чипы хэшрейт ноль и температуру 15 гр.разумеется в силу ожидания абсолютной халявы был заменён 27 чип и плата прекрасно таки завелась  (ибо была прогрета.ну а дальше цирк с конями.хэшрейт появляется либо когда асик на улице при минусовой почти температуре.либо когда плата вынута из корпуса и сама себя прогревает.по логике вещей это отвал одного из чипов?или pic с ума сходит по показаниям температуры?от этого железа можно ждать чего угодно ,так что лучше сто раз прочитать и 10 раз переспросить.Можно ли для проверки с л3+ кинуть pic как писалось выше?)))логи обязательно скину вечером как доберусь до аппарата.

Share this post


Link to post
Share on other sites

А не попробовали 62 чипос махнуть или пропаять?

Share this post


Link to post
Share on other sites

Крутится такая мысль.датчик температуры как я понял прицеплен последовательно за 62 чипом?то есть если между 26 и 62 чипом что то в отвале то показания температуры будут такие же.плюс маловероятно что сам чип целиком в отвале,скорее всего бга внутри чипа.датчик кстати менял

Share this post


Link to post
Share on other sites
1 час назад, tetra3420 сказал:

или pic с ума сходит по показаниям температуры?....Можно ли для проверки с л3+ кинуть pic как писалось выше?

PIC с температурой напрямую никак не связан. Он управляет питанием и хранит в себе настройки платы (частоты, рабочее напряжение, плохие чипы, калибровки датчика температуры и т.п.), плюс в нем вотчдог (в терминах китайцев heart beat). 

Про замену PIC c L3+ писалось в контексте завышения рабочих частот. Если у вас частоты соответствую заявленному хэшрейту, то смысла в такой замене нет. Если хотите понизить частоту для проверки стабильности работы, то попробуйте сначала программные методы: прошивка с фиксированной частотой или ручная установка частоты с помощью скрытых меню в веб-интерфейсе или через конфиги по ssh.

1 час назад, tetra3420 сказал:

датчик температуры как я понял прицеплен последовательно за 62 чипом?то есть если между 26 и 62 чипом что то в отвале то показания температуры будут такие же.плюс маловероятно что сам чип целиком в отвале,скорее всего бга внутри чипа.датчик кстати менял

Я конечно сам точно не разобрался, но по одной простой причине датчик температуры не может быть последовательно подключен за 62-м чипом: асики опрашиваются по UART, а датчик температуры по I2C. Там схема примерно такая: в качестве внешнего датчика для tmp451 используется встроенный в 62 асик термодатчик, а опрос tmp451 ведется через встроенный в 61 (а может и в 62) асик i2c интерфейс ну и дальше гонится по uart по цепочке к 1-му асику и в контрольку.

Поправьте меня если в чемто ошибся.

Так что если вы уже поменяли tmp451, то пропаяйте 61 и 62 асики, не поможет - меняйте их.

Share this post


Link to post
Share on other sites

@Splinter  датчик висит на  15 и 16 контакте(по разводке платы это хорошо видно) среднего чипа, последней тройки чипов. Сами считайте - вроде 62. в остальном все верно.

Edited by profipc

Share this post


Link to post
Share on other sites

@profipc 15 и 16 выводы это как раз встроенный полупроводниковый датчик температуры, к нему и подключается tmp451 как к датчику (вы правы, именно к 62 асик). А вот по i2c tmp451 должна подключаться к 17 и 18 ногам асик, а вот какого 61 или 62 точно не скажу.

Schematic.GIF

Edited by Splinter

Share this post


Link to post
Share on other sites
6 минут назад, Splinter сказал:

@profipc 15 и 16 выводы это как раз встроенный полупроводниковый датчик температуры, к нему и подключается tmp451 как к датчику (вы правы, именно к 62 асик). А вот по i2c tmp451 должна подключаться к 17 и 18 ногам асик, а вот какого 61 или 62 второго точно не скажу.

Schematic.GIF

на 61 asic 17 и 18 ноги не используются. на 62 есть пятаки уходящие в плату по этим контактам. на 63 также - но там вроде Вы писали, они идут на светодиоды RX TX.

Share this post


Link to post
Share on other sites

@profipc на 63 светодиоды это точно. Значит всетаки он полностью подключен к 62-му чипу. К сожалению у меня на разборе нет платы с tmp451, а то я давно хочу разрисовать последний домен.

P.S. Человек со схемой подтвердил, что tmp451 полностью подключен к 62-му чипу, спасибо ему.

Edited by Splinter

Share this post


Link to post
Share on other sites

Контрольная плата ни как не реагирует на подключение питания, не горит ни один индикатор, ни с подключенными хешами ни без них, на кнопки тоже 0 реакции. Есть шансы оживить ее или в помойку? 

Share this post


Link to post
Share on other sites

@Xtrojan  Шансы есть, несите в ремонт.

 

Share this post


Link to post
Share on other sites

Прошу помощи по хешплате S9.

контролька C41 v. 1.20, рабочая. блейд S9 v4.31C не хочет работать.

Пишет Chain[J6] has 0 asic

Вкратце лог:

Скрытый текст

.....

[    1.148973] mmc0: no vqmmc regulator found
[    1.152982] mmc0: no vmmc regulator found
[    1.196560] mmc0: SDHCI controller on e0100000.ps7-sdio [e0100000.ps7-sdio] using ADMA
[    1.205249] usbcore: registered new interface driver usbhid
[    1.210766] usbhid: USB HID core driver
[    1.215476] nand: device found, Manufacturer ID: 0x2c, Chip ID: 0xda
[    1.221769] nand: Micron MT29F2G08ABAEAWP
[    1.225738] nand: 256MiB, SLC, page size: 2048, OOB size: 64
[    1.231690] Bad block table found at page 131008, version 0x01
[    1.237934] Bad block table found at page 130944, version 0x01
[    1.243983] 3 ofpart partitions found on MTD device pl353-nand
[    1.249753] Creating 3 MTD partitions on "pl353-nand":
[    1.254855] 0x000000000000-0x000002000000 : "BOOT.bin-env-dts-kernel"
[    1.262928] 0x000002000000-0x00000b000000 : "angstram-rootfs"
[    1.270239] 0x00000b000000-0x000010000000 : "upgrade-rootfs"
[    1.279170] TCP: cubic registered
[    1.282410] NET: Registered protocol family 17
[    1.287134] Registering SWP/SWPB emulation handler
[    1.293021] regulator-dummy: disabling
[    1.297420] UBI: attaching mtd1 to ubi0
[    1.820795] UBI: scanning is finished
[    1.832355] UBI: attached mtd1 (name "angstram-rootfs", size 144 MiB) to ubi0
[    1.839432] UBI: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    1.846175] UBI: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    1.852877] UBI: VID header offset: 2048 (aligned 2048), data offset: 4096
[    1.859736] UBI: good PEBs: 1152, bad PEBs: 0, corrupted PEBs: 0
[    1.865704] UBI: user volume: 1, internal volumes: 1, max. volumes count: 128
[    1.872836] UBI: max/mean erase counter: 96/57, WL threshold: 4096, image sequence number: 1984962504
[    1.882041] UBI: available PEBs: 0, total reserved PEBs: 1152, PEBs reserved for bad PEB handling: 40
[    1.891257] UBI: background thread "ubi_bgt0d" started, PID 1080
[    1.891262] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[    1.895176] ALSA device list:
[    1.895179]   No soundcards found.
[    1.911617] UBIFS: background thread "ubifs_bgt0_0" started, PID 1082
[    1.940639] UBIFS: recovery needed
[    2.027506] UBIFS: recovery completed
[    2.031168] UBIFS: mounted UBI device 0, volume 0, name "rootfs"
[    2.037114] UBIFS: LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[    2.046204] UBIFS: FS size: 128626688 bytes (122 MiB, 1013 LEBs), journal size 9023488 bytes (8 MiB, 72 LEBs)
[    2.056107] UBIFS: reserved for root: 0 bytes (0 KiB)
[    2.061146] UBIFS: media format: w4/r0 (latest is w4/r0), UUID 56FDF5FA-8D29-4AA7-95D4-1C2E28C7C4E9, small LPT model
[    2.072663] VFS: Mounted root (ubifs filesystem) on device 0:11.
[    2.080083] devtmpfs: mounted
[    2.083189] Freeing unused kernel memory: 204K (c06d2000 - c0705000)
[    2.928165] random: dd urandom read with 0 bits of entropy available
[    3.316576] 
[    3.316576] bcm54xx_config_init
[    3.926580] 
[    3.926580] bcm54xx_config_init
[    6.927415] xemacps e000b000.ps7-ethernet: Set clk to 24999999 Hz
[    6.933506] xemacps e000b000.ps7-ethernet: link up (100/FULL)
[   19.466372] In axi fpga driver!
[   19.469476] request_mem_region OK!
[   19.472829] AXI fpga dev virtual address is 0xdf9fc000
[   19.477971] *base_vir_addr = 0x8c510
[   19.492675] In fpga mem driver!
[   19.496184] request_mem_region OK!
[   19.499792] fpga mem virtual address is 0xe2000000
[   20.266587] 
[   20.266587] bcm54xx_config_init
[   20.896553] 
[   20.896553] bcm54xx_config_init
[   23.897408] xemacps e000b000.ps7-ethernet: Set clk to 24999999 Hz
[   23.903431] xemacps e000b000.ps7-ethernet: link up (100/FULL)
Detect 512MB control board of XILINX
Miner Type = S9
set_reset_allhashboard = 0x0000ffff
set_reset_allhashboard = 0x00000000
set_reset_allhashboard = 0x0000ffff
set_reset_allhashboard = 0x0000ffff
Check chain[5] PIC fw version=0x03
Fix freq=650 Chain[5] voltage_pic=108 value=880
set_reset_allhashboard = 0x0000ffff
set_reset_allhashboard = 0x00000000
Chain[J6] has 0 asic
set_reset_hashboard = 0x00000020
set_reset_hashboard = 0x00000000
retry Chain[J6] has 0 asic
set_reset_hashboard = 0x00000020
set_reset_hashboard = 0x00000000
retry Chain[J6] has 0 asic
set_reset_hashboard = 0x00000020
set_reset_hashboard = 0x00000000
retry Chain[J6] has 0 asic
set_reset_hashboard = 0x00000020
set_reset_hashboard = 0x00000000
retry Chain[J6] has 0 asic
set_reset_hashboard = 0x00000020
set_reset_hashboard = 0x00000000
retry Chain[J6] has 0 asic
set_reset_hashboard = 0x00000020
set_reset_hashboard = 0x00000000
retry Chain[J6] has 0 asic
miner total rate=0GH/s fixed rate=0GH/s

Miner fix freq ...
max freq = 100
set baud=16
setStartTimePoint total_tv_start_sys=64 total_tv_end_sys=65
restartNum = 2 , auto-reinit enabled...
do read_temp_func once...
do check_asic_reg 0x08
Done check_asic_reg
set FAN speed according to: temp_highest=0 temp_top1[PWM_T]=0 temp_top1[TEMP_POS_LOCAL]=0 temp_change=0 fix_fan_steps=0
set full FAN speed...
FAN PWM: 100
read_temp_func Done!
CRC error counter=0

 

При запуске на блейде горит только диод TF. Чипы греются как на холостых, питание минуты через полторы неудачных "set reset hashboard" выключаются, диод тухнет.

Вольтаж на дросселе 9.4В.

Разница между доменами чётко 0.443В +/- какие-то там сотые доли, однако между 50-51-52 и 47-48-49 чипами 0.528В - это единственное из ряда вон выходящее.

Конечные строки лога другие там где про PWM вентилей, ибо этот лог с 3-пиновыми вентиляторами, я навесил чтобы ночью семью не будить.

Что ещё проверить? Как запустить?

 

 

 

 

Edited by Oz64

Share this post


Link to post
Share on other sites

То есть ,как я и говорил ,дефолтная температура 15 гр. отсутствие хешрейта +положительная реакция на прогрев говорит об отвале одного и более чипов в цепи от первого до 62-го?в моем случае 26-62.есть смысл через логи искать дефектный чип?некоторое время назад один форумчанин сообщил что подобные мероприятия без тестера хэшборд это трата сил в никуда))

Share this post


Link to post
Share on other sites

@tetra3420 

Народ же как то ремонтить без тестеров.

Кстати кто-то спрашивал про платы у которых при прогреве все чипы заводяться. До прогрева показывает меньше чипов. И ругается на считывание температуры 62 чипом. Замена в том числе 62 чипа решила проблему на 2 лезвиях. Не статистика, но все же.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Topics

    • Обновленные Antminer E3 смогут добывать ETH и ETC до октября 2020

      Майнинговая компания Bitmain выпустила обновление прошивки для Antminer E3, благодаря чему они продолжат добычу ETH и ETC до октября 2020 года. Ранее сообщалось, что в апреле модели Antminer E3, предназначенные для майнинга ETH и ETC, перестанут быть актуальными из-за низкой энергоэффективности и невозможности обрабатывать крупные файлы направленного ациклического графа (DAG).   По расчетам майнингового пула 2Miners, отключение этих майнеров существенно отразилось на хэшрейте сети

      in Новости криптовалют

    • Переделка БП от М3 для Antminer

      Доброго времени суток форумчане.Наверное многим будет интересно как переделать блок питания от М3 для питания тех же S9,T9.Блок лежит без дела,пропадают более 2кВт,можно было бы под разгон антмайнеров пустить.Может кто уже делал, поделитесь пожалуйста.

      in Блоки питания, ИБП, силовая часть

    • Лечение Antminer S9 T9+ L3+ полная инструкция

      ВСЕ ДЕЙСТВИЯ ОСУЩЕСТВЯЕТЕ НА СВОЙ СТРАХ И РИСК!  Лечим Nightswitcher, Antbuild, болезнь двух светодиодов, зацикливание мигания синего светодиода на L3+, мертвые платы L3+ и другое   Инструкция по лечению асика Antminer L3+ L3++   1. Снимаем контрольную плату 2. Скачиваем L3+Tools с официального сайта Bitmain, разархивируем и записываем на SD карту (FAT32)  https://service.bitmain.com/support/download?product=Flashing SD card with image 3. Устанавливаем карту в

      in ASIC/FPGA майнеры

    • Antminer. Все модели. Вопросы, помощь, обсуждение.

      В этой теме обсуждается вся линейка продукции компании BITMAIN. А также все вопросы, связанные с использованием, настройкой, модернизацией и прочие околоANTовые вопросы.   Основные продукты:     Antminer S7 Он и правда существует!!! - https://forum.bits.media/index.php?/topic/18603-antminer-s1-s2-s3-s3-s4-s5-c1-s7-voprosy-pomosch-obsuzhdenie/page-542?p=309969&do=findComment&comment=309969   Прошивки официальные:   Образы прошивок для всех майнеров с BB

      in ASIC/FPGA майнеры

    • Antminer Z11

      Вышел antminer z11.  Технические характеристики:    

      in ASIC/FPGA майнеры

×
×
  • Create New...