Перейти к содержимому


Фотография

CGMINER

CGMINER miner цгмайнер майнер цгминер

Сообщений в теме: 3429

#3001 CrusaderI

CrusaderI

    Новичок

  • Пользователи
  • Pip
  • 2 сообщений

Отправлено 26 February 2014 - 20:35

Всем привет! Люди, помогите советом - майнер запускается, видит обе карточки, но запускает только одну, находит 3 решения и комп виснет наглухо. Винду переставлял уже 5 раз. Кто знает в чем дело? CGMiner 3.7.2, Win7 64, ничего не менял и не перенастраивал. 


Сообщение отредактировал CrusaderI: 26 February 2014 - 20:36

  • -1

#3002 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7103 сообщений

Отправлено 26 February 2014 - 21:47

the11, нормально все..теперь жди.. :)


  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#3003 glukolog

glukolog

    Новичок

  • Пользователи
  • Pip
  • 48 сообщений

Отправлено 26 February 2014 - 23:26

Много страниц назад искали ответ почему cgminer к примеру на 5970 дает черный экран (black screen)

Ответов не видел, потому даю свой вариант.
Косяк в adl не корректно возвращается скорость куллера (у меня вообще не подключен)
Как вариант решения берем исходники cgminer версии 3.7.2
редактируем adl.c там есть функция __gpu_fanspeed
вот первой строкой ставим return 1000;

static inline int __gpu_fanspeed(struct gpu_adl *ga)
{
     return 1000;

как-то так... Перекомпиливаем и всё работает и показывает 1000 оборотов ну или по настроению 777

ну можно ещё ключик -T или --text-only, но мне как-то стандартный вид приятен и температуру можно посматривать


  • 0

#3004 Evgeny

Evgeny

    Новичок

  • Пользователи
  • Pip
  • 3 сообщений

Отправлено 27 February 2014 - 00:22

Evgeny,

-g 2 -I 13 -tc 24000 частоты пока не прописывай.

или -g 1 -I 20 -tc 24000 

 

тут главное если g1 то "I" можно ставить до 20, а если -g 2 то после 13и будут хардвары. и памяти в комп три гига под винду(хоть и 32битную) надо.

изменил с -g 1 -g 2 скорость поднялась до 520

получилось вот так--cgminer.exe --scrypt -u user.1 -p pass -o  stratum+tcp://hot.wemineltc.com:3333 --gpu-platform 0 -I 13 -g 2 -w 256 --thread-concurrency 8192 --gpu-powertune 20

до 24000 поднять не могу ,ругается.
на моём компе 2.75 гига оперативки, есть ли подтвержденные факты что необходимо поднять до 4 гига? во время работы майнер кушает 35 мегапамяти.
 


  • 0

#3005 gamespb

gamespb

    Пользователь

  • Пользователи
  • PipPip
  • 56 сообщений

Отправлено 27 February 2014 - 00:33

Evgeny,

да , под виндой - для видяхи с 2я гигами нужно 3 гига оперативы и это на 32х битной винде.

tc поднимать до максимально возможного посматривая на KHs. бывает увеличиваем tc а скорость падает.


  • 0

#3006 gach

gach

    Новичок

  • Пользователи
  • Pip
  • 28 сообщений
  • ГородСПб

Отправлено 27 February 2014 - 10:54

gach, встроенная Интел не умеет читать через драйвер АМД ... температуру / обороты кулера железяки от производителя-конкурента. Переткните фишку монитора в R9 270 и будет счастье  ;) 

Нужно смотреть чтобы было много Accepted, гдето каждые 3-5 секунд примерно - а у Вас сложность 800 (pool difficulty changed to ...) просто недосягаема на 400кх/с, тут нужна скорость 3500 кх/с для нахождения решений! Нужен пул где можно регулировать сложность - для 1 х R9 270 оптимальная сложность 64...128 

А подскажите тогда пожалуйста такой пул. А то чет у меня реджектов 1/3 мне кажется это многовато. 


  • 0

#3007 comrade

comrade

    Пользователь

  • Пользователи
  • PipPip
  • 69 сообщений

Отправлено 27 February 2014 - 11:44

 

А подскажите тогда пожалуйста такой пул. А то чет у меня реджектов 1/3 мне кажется это многовато. 

 

Я пользуюсь wemineltc.com . Там можно настроить сложность своих шахтёров:


Diff.jpg


 


  • 0

#3008 donsergio

donsergio

    Новичок

  • Пользователи
  • Pip
  • 1 сообщений

Отправлено 27 February 2014 - 21:18

Всем привет. есть 5 видеокарт 3х7970 и 2х7950 стоят на одной ферме. В cgminer они определяются не в той последовательности в которой стоят (температуру и rpm вентилятора показывает от одной карты а хешрейт в этой же строчке от другой карты). получается что когда одна из карт перегревается, cgminer начинает снижать интенсивность но она снижается на другой карте. Подскажите как это можно исправить?


Сообщение отредактировал donsergio: 27 February 2014 - 21:34

  • 0

#3009 Neosaan

Neosaan

    Продвинутый пользователь

  • Пользователи
  • PipPipPip
  • 2078 сообщений

Отправлено 27 February 2014 - 22:33

Ребята) Помогите пожалуйста) Голова плавится)

Видяшка R290 вот запускаю батником  вот он       cgminer.exe --scrypt -u ххх.ххх -p ххххх -o stratum+tcp://dogpool.ru:3333 -w 256 -l 20 -g 1 --gpu-engine 900 --gpu-memclock 1300

 

Показывает что работает на 10 к\хешей)

 

Да и по звуку слышно что не работает нихрена и в афтербурнере загрузка еле еле)

Что добавть нужно?)


  • 0

#3010 shayne

shayne

    Новичок

  • Пользователи
  • Pip
  • 15 сообщений

Отправлено 27 February 2014 - 22:39

Много страниц назад искали ответ почему cgminer к примеру на 5970 дает черный экран (black screen)

Ответов не видел, потому даю свой вариант.
Косяк в adl не корректно возвращается скорость куллера (у меня вообще не подключен)
Как вариант решения берем исходники cgminer версии 3.7.2
редактируем adl.c там есть функция __gpu_fanspeed
вот первой строкой ставим return 1000;



static inline int __gpu_fanspeed(struct gpu_adl *ga)
{
     return 1000;

как-то так... Перекомпиливаем и всё работает и показывает 1000 оборотов ну или по настроению 777

ну можно ещё ключик -T или --text-only, но мне как-то стандартный вид приятен и температуру можно посматривать

А в какой среде вы компилируете исходники?


  • 0

#3011 gamespb

gamespb

    Пользователь

  • Пользователи
  • PipPip
  • 56 сообщений

Отправлено 27 February 2014 - 23:45

Neosaan,

"gpu-platform" : "0",

 или 1

в cgminer.conf


  • 0

#3012 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7103 сообщений

Отправлено 28 February 2014 - 00:38

gamespb, при чем тут конфиг файл-он батник запускает..

Neosaan, Оперативы то нормально в компютере? пробуй так 

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer.exe --scrypt --gpu-memclock 1500 --gpu-engine 1000 --worksize 512 --intensity 20 --thread-concurrency 24550 --auto-fan --temp-target 80 --gpu-powertune 20


  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#3013 gamespb

gamespb

    Пользователь

  • Пользователи
  • PipPip
  • 56 сообщений

Отправлено 28 February 2014 - 01:09

Lion74,

 

сообразит как в ком. строку подставить то,


  • 0

#3014 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7103 сообщений

Отправлено 28 February 2014 - 18:15

gamespb, ну так то, да..


  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#3015 kosvil

kosvil

    Пользователь

  • Пользователи
  • PipPip
  • 86 сообщений

Отправлено 28 February 2014 - 21:33

Прошу помощи, конфиг не запускается. Я вообще написал об этом здесь, но всё же здесь более подходящая ветка форума.

 

Конфиг:



{
"pools" : [
{
"url" : "stratum+tcp://coinotron.com:3339",
"user" : "ххх",
"pass" : "ххх"
},

]
,
"intensity" : "19,19",
"vectors" : "1,1",
"worksize" : "256,256",
"kernel" : "phatk,phatk",
"lookup-gap" : "2,2",
"thread-concurrency" : "15232,16192",
"gpu-engine" : "955,1100",
"gpu-fan" : "75,50",
"gpu-memclock" : "1249,1500",
"gpu-powertune" : "20,20",
"temp-cutoff" : "95,95",
"temp-overheat" : "85,85",
"temp-target" : "75,75",
"api-port" : "4028",
"expiry" : "120",
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "2",
"log" : "5",
"queue" : "5",
"scan-time" : "60",
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}

Выдаёт такое:

Безымянный2.jpg

Как я понял надо что-то в строчке "pools" : [ написать, но что? У меня всё ниже прописано, что за пул, воркер и пароль.

И ещё - надо ли добавлять ключ -d?  у меня 2 карты, и соответственно настройки через запятую для 2 карт


  • 0

#3016 Oberon

Oberon

    Новичок

  • Пользователи
  • Pip
  • 4 сообщений

Отправлено 28 February 2014 - 21:38

Прошу помощи только спецов, потанцевать с бубном сам умею. Суть в чем, на полностью рабочем железе меняю одну 7700 на 2 две 270Х, сношу Win7 x86, ставлю Win7 x64. Периодически с разными промежутками от часа до суток получаю зависание cgminer, винда интересуется типа завершить работу\искать решение в инете. Соответственно винда работает, перезапуск батника восстанавливает работу майнера, но всё же Ваше мнение, куда капать - железо\ОС\дрова\ПО ... кривые руки ?


  • 0

#3017 Lion74

Lion74

    Кусатель флудеров

  • Супермодераторы
  • 7103 сообщений

Отправлено 28 February 2014 - 22:09

Oberon,я тут когда банку готовил для микро-фермочки-последовал совету из форума: в биосе поотключал все, что не нужно для работы (звуковуха, ком-лпт порты и т.п. ..в винде поубирал все энергосберегающие режимы, поставил дрова 13.12 без ССС..вроде все работает норм..


Сообщение отредактировал Lion74: 28 February 2014 - 22:09

  • 0
Универсальный ответ на все вопросы-необходимо разработать адекватные меры..которые будут эффективны
ПРАВИЛА ФОРУМА прочти, а потом пиши..но вдумчиво..https://forum.bits.m...§ion=boardrules

#3018 ror_

ror_

    Пользователь

  • Пользователи
  • PipPip
  • 68 сообщений

Отправлено 28 February 2014 - 23:03

Прошу помощи только спецов, потанцевать с бубном сам умею. Суть в чем, на полностью рабочем железе меняю одну 7700 на 2 две 270Х, сношу Win7 x86, ставлю Win7 x64. Периодически с разными промежутками от часа до суток получаю зависание cgminer, винда интересуется типа завершить работу\искать решение в инете. Соответственно винда работает, перезапуск батника восстанавливает работу майнера, но всё же Ваше мнение, куда капать - железо\ОС\дрова\ПО ... кривые руки ?

Что за карты?

Можно попробовать понизить частоты. Мне помогло.


  • 0

#3019 shayne

shayne

    Новичок

  • Пользователи
  • Pip
  • 15 сообщений

Отправлено 01 March 2014 - 09:47

Прошу помощи, конфиг не запускается. Я вообще написал об этом здесь, но всё же здесь более подходящая ветка форума.

Конфиг:

{"pools" : [{"url" : "stratum+tcp://coinotron.com:3339","user" : "ххх","pass" : "ххх"},],"intensity" : "19,19","vectors" : "1,1","worksize" : "256,256","kernel" : "phatk,phatk","lookup-gap" : "2,2","thread-concurrency" : "15232,16192","gpu-engine" : "955,1100","gpu-fan" : "75,50","gpu-memclock" : "1249,1500","gpu-powertune" : "20,20","temp-cutoff" : "95,95","temp-overheat" : "85,85","temp-target" : "75,75","api-port" : "4028","expiry" : "120","gpu-dyninterval" : "7","gpu-platform" : "0","gpu-threads" : "2","log" : "5","queue" : "5","scan-time" : "60","temp-hysteresis" : "3","shares" : "0","kernel-path" : "/usr/local/bin"}
Выдаёт такое:
attachicon.gifБезымянный2.jpg
Как я понял надо что-то в строчке "pools" : [ написать, но что? У меня всё ниже прописано, что за пул, воркер и пароль.
И ещё - надо ли добавлять ключ -d? у меня 2 карты, и соответственно настройки через запятую для 2 карт
{
"url" : "stratum+tcp://coinotron.com:3339",
"user" : "ххх",
"pass" : "ххх"
}

]
Запятая лишняя после закрытия ковычки. Ключ -d на сколько я понимаю ставится если нужно использовать только одну ВК

Сообщение отредактировал shayne: 01 March 2014 - 09:52

  • 0

#3020 kosvil

kosvil

    Пользователь

  • Пользователи
  • PipPip
  • 86 сообщений

Отправлено 01 March 2014 - 19:49

shayne, спасибо, по ходу, в этом и было дело.

Но в итоге после запуска вместо изображения появились полосы и пришлось перезагружать это всё. Карты - 7870 и 270х. Вообще из-за чего я занялся конфигом? Потому что общий батник давал результат как здесь. А когда запускал по батнику для каждой карты 270х подхватывала настройки от 7870, не знаю почему (в батнике у неё свои настройки прописаны. Например запускашь батник для 270х, по аиде видно, частоты меняются на 1100/1500, с скорость - 470кх, потом запускаешь батник для 7870 и частоты 270х меняются на те, что прописаны для 7870 - 950/1250 и скорость становится около 410кх.. Вот уже неделю с этим бьюсь - ничего не выходить, не получается заставить работать 2 карты в одной системе...


  • 0





Темы с аналогичным тегами CGMINER, miner, цгмайнер, майнер, цгминер

Количество пользователей, читающих эту тему: 9

0 пользователей, 9 гостей, 0 анонимных