Перейти к содержимому

Рекомендуемые сообщения

(изменено)

Поставил себе линукс, и теперь не могу нормально запустить ccMiner.

Пишет: "Unable to query CUDA driver version! Is an nVidia driver installed?"

 

Кто-нибудь подскажет в чем у меня проублема?

 

С линукс общаюсь совсем не давно - несколько дней.

 

Скачал исходники, еле еле собрал из них запускной файл, было много мучений в настройке компиляции.

Наконец то скомпилил, и вот.... в архиве для винды в данной версии есть несколько файлов для разных компьют вершен... а тут получился один файл ccminer в папке и все... разделения по версиям куда ядер нет.

 

 

запускаю так:

./ccminer -a x11 -o stratum+tcp://eu1.coinking.io:6666 -u safocl.11 -p x

 

 

выдает вот это:

 

*** ccMiner for nVidia GPUs by Christian Buchner and Christian H. ***

This is version 1.0 (beta)

based on pooler-cpuminer 2.3.2 © 2010 Jeff Garzik, 2012 pooler

based on pooler-cpuminer extension for HVC from

https://github.com/heavycoin/cpuminer-heavycoin

and

http://hvc.1gh.com/

Cuda additions Copyright 2014 Christian Buchner, Christian H.

LTC donation address: LKS1WDKGED647msBQfLBHV3Ls8sveGncnm

BTC donation address: 16hJF5mceSojnTD3ZTUDqdRhDyPJzoRakM

YAC donation address: Y87sptDEcpLkLeAuex6qZioDbvy1qXZEj4

[2015-08-08 11:03:44] Unable to query CUDA driver version! Is an nVidia driver installed?

Изменено пользователем Uliss

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
(изменено)
Пишет: "Unable to query CUDA driver version! Is an nVidia driver installed?"

 

Что, дословно, означает: "Невозможно выполнить запрос версии  драйвера CUDA! Драйвер nVidia установлен?"

 

Что там у вас с видеокартами и дровами?

Изменено пользователем Uliss

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
(изменено)

видеокарта GTX560 драйвер 340, с дравами выше версиии не могу поставить куда туллкит... а без него компилироваться отказывается.

 

 

и подскажите в Linux Mint 17.2 как установить драййвер видеокарты с файла *************.run???

пишет, что запущен Хсервер, и установка не может быть продолжена, а команды отключения Хсервера не подходят для минта... какая команда для отключения Хсервера в минт???

 

 

спс всем ответившим.... ))) разобрался вроде с проблемой, проверял я по версии поддерживаемых куда ядер пакет по скачанным виндусовским пакетам, но оказывается к разным версиям виндусовским шла одна и та же версия на гитхабе... и качая архив с исходниками качал все время один и тот же пакет....

 

но надо было проверять в уже скачанном пакете файл редми по версии....

 

просто ужас, гитхаб троллит всех

 

 

и чото старый исходник не содержит всех нужных файлов, пришлось копировать из нового

 

 

ёпрст, увы, снова почему то пишет так же.

 

все, вроде заехало... помогло установка драйвера прям из пакета CUDA... до ентого стоял тот же драйвер 346, и 340 пробывал ноль эффекта, а вот с кудовским пошло)) ужас

Изменено пользователем Uliss

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
     *** ccMiner for nVidia GPUs by Christian Buchner and Christian H. ***
	             This is version 1.0 (beta)
	  based on pooler-cpuminer 2.3.2 (c) 2010 Jeff Garzik, 2012 pooler
	  based on pooler-cpuminer extension for HVC from
	       https://github.com/heavycoin/cpuminer-heavycoin
			and
	       http://hvc.1gh.com/
	Cuda additions Copyright 2014 Christian Buchner, Christian H.
	  LTC donation address: LKS1WDKGED647msBQfLBHV3Ls8sveGncnm
	  BTC donation address: 16hJF5mceSojnTD3ZTUDqdRhDyPJzoRakM
	  YAC donation address: Y87sptDEcpLkLeAuex6qZioDbvy1qXZEj4
[2015-08-16 15:46:36] 1 miner threads started, using 'x11' algorithm.
[2015-08-16 15:46:36] Starting Stratum on stratum+tcp://cann.suprnova.cc:4442
[2015-08-16 15:46:36] Stratum detected new block
[2015-08-16 15:46:37] thread 0: 1048577 hashes, 41055 khash/s
[2015-08-16 15:46:47] Stratum detected new block
[2015-08-16 15:46:47] thread 0: 2065629185 hashes, 212833 khash/s

вот что он мне пишет.... скорость 200 мегахешей.... почему такое чудо?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@safocl, да пофиг, какую он скорость пишет - акцепты есть?

А скорость на ПУЛе смотрите реальную.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@safocl, да пофиг, какую он скорость пишет - акцепты есть?

А скорость на ПУЛе смотрите реальную.

в том то и дело что нет, шары не подтверждаются и на сайте скорасти нет, пробывал на многих, на которых раньше точно работало, так на 10-15 примерно разных пулах....

грусть пичаль. кстати собрал cudaminer - с ним все впаряде. и вся проблема с cuda драйвером решилась установкой драйвера 352 с сайта нвидиа. с другими даже с сайта не хатит...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
(изменено)

народ если кому понадобится, то разобрался с данной проблемой только одним способом....

только этот пакет подошел к моей видюхе, все новые пакеты отказываются с ней нормально работать:

https://github.com/KBomba/ccminer-KBomba/tree/ccminer-for-compute-2.x

 

именно у кого компьют 2.1

Изменено пользователем safocl

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Апну темку. Собрал ccminer под Debian 8 x64, всё работает. Но не могу засунуть в screen. Если делаю руками - сначала screen -S ccminer, потом строка запуска майнера - всё ОК. Если делаю одной строчкой (как обычно делалось через init.d и вообще) - вылетает сразу же. Никто такой косяк не ловил?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×