Jump to content

Nosych

Пользователи
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

0 Обычный

About Nosych

  • Rank
    Новичок

Recent Profile Visitors

333 profile views
  1. Где бы майнер не создавал DAG, он всё-равно не сможет засунуть его в видеопамять, которая меньше DAGа. Пробовал разные майнеры эфира не один не запускается - все выдают ошибку out of memory. SWAP увеличил - безрезультатно. Скрины: 1. Последний ethminer (0.17) майнит eth 2. Последний ethminer (0.17) майнит etc (там, кстати, видно, что даже у etc размер DAG 2,898GB) 3. Старый ethminer.
  2. Карты 8шт х 1060 - это написано. На скрине видно, что майнер - ethminer, значит валюта - эфир. Что-нибудь ещё спросите? UPD Проблема, как я понял, глобальная: DAG перевалил за 3Гига и на карточках с 3-хгиговой памятью больше не майнится. А у меня все карты GTX-1060 3GB. Так что, я всё.
  3. Всё работало, работало месяцами, никаких изменений не вносил, ничего не трогал и вдруг сегодня выдаёт ошибку: CUDA error ..... out of memory (см.скрин). Ребутнул, все разгонные настройки применились без ошибок, начался майнинг и сразу ошибка. На всякий случай увеличил swap с 1 до 4 ГБ - не помогло. Та же ошибка после ребута. Плата ASUS H-270 Plus, 8x1060 (разные), RAM - DDR4 4GB. Прошу помощи: какой памяти ему не хватает? Заранее благодарен.
  4. Как-то я об этом не подумал! Завтра попробую. Спасибо. Update: Не прошло и месяца, как я добрался до фермы. Пробовал по всякому переставлять сплиттеры в разные pci-e порты. Работает только схема: 4 карты в один сплиттер + 3 карты в другой сплиттер + 1 карта в pci-e порт (неважно в какой). В остальных комбинациях комп зависает даже не начав загружать Ubuntu - после ресета сразу чёрный экран и тишина.
  5. Прошу совета. Есть мать ASUS H110M-K, на ней 2 pci-e 1x слота, в оба вставлены разветвители 4 pci-e 1x to 1 pci-e 1x. К разветвителям подключены 7 1060. Подключаю 8-ую 1060 в разветвитель - ферма не загружается, подключаю её же в pci-e 16x всё взлетает и работает как часы. Пробовал ставить другой разветвитель - результат тот же. Как это победить? Ибо хочу на эту мать засунуть 9 карт.
  6. В копилку знаний (хотя, может быть, это очевидная вещь): Майнер вдруг выдал ошибку и после перезагрузки пропала одна карта из 7. Никаких модернизаций не проводилось, обновления не устанавливались - всё работало штатно более месяца. Полез разбираться - Убунта видит все 7 карт, подключенные к PCI, nvidia-smi видит только 6 карт, соответственно xorg разгоняет только 6, и майнер майнит только шестью. На картинке видно, что nvidia-smi не видит карту по адресу 0a:00.0. Пробовал менять карты местами, менял райзер на новый, подключал карту к другому разветвителю. Результат - 0. Помогло подключение питания райзера к другому БП. Видимо нагрузка на этот БП снизилась. Всё выше сказанное касается в первую очередь нищебродов, вроде меня, майнящих на дешёвых компьютерных блоках питания. У меня схема питания была следующая: AEROCOOL VX-650 - система + 2 карты (питание райзера + доп.питание карты) AEROCOOL VX-600 - 3 карты (питание райзера + доп.питание карты) AEROCOOL VX-550 - 2 карты (питание райзера + доп.питание карты). Как ни странно, но "просел" VX-600 ( с 3 картами). Временно снял с него питание райзера и перекинул на VX650, доп.питание карты пока оставил на VX600.
  7. Мониторинг. Раз в минуту запрашиваешь currentHashrate на сайте, сравниваешь с каким-то номинальным (в зависимости от мощности фермы), и если ниже, то смотришь,что не так с фермой. У меня на 7х1060 скорость плавает от 120 до 170 (по показаниям сайта) стало быть, если упала ниже 100, значит что-то не так или с фермой или с инетом.
  8. А можно поподробнее. Майню на ethermine.org. У них свой api, по запросу https://api.ethermine.org/miner/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/currentStats выдаёт целый ряд значений. Как выбрать одно-два нужных?
  9. Может этого бы и не было, но сейчас всё работает. Недавно добавлял карточку, xorg.conf сгенерился без проблем.
  10. Решил поставить на ферму vnstsat, чтобы узнать сколько трафика жрёт ethminer. После этого ethminer начал вылетать 2-3 раза за сутки. Удивился, подождал 3 дня - ситуация не изменилась. Удалил vnstat со всеми зависимостями - ethminer работает стабильно без вылетов. У всех так? Кто чем меряет трафик?
  11. @myuriy Ни на что не претендую. В моём случае сработало, я поделился с народом.
  12. Поделюсь опытом. Возникла проблема когда на исправно работающем риге с пятью картами, после установки шестой, не генериться xorg.conf Есть ASUS H110M-K (2 PCI-E 1X, 1 PCI-E 16X) под Ubuntu 16.04 В первый PCI-E 1X воткнут сплиттер на 4 входа к нему подключены 4 райзера, во второй PCI-E 1X воткнут пятый райзер .- по такой схеме 5 GTX1060 работают прекрасно. Решил докупить шестую GTX1060 и воткнуть через райзер в последний свободный порт PCI-E 16X. Воткнул, обновил список PCI портов sudo udate-pciids, проверил как система видит карты через lspci | grep VGA. Система видит все 6 карт + 1 встроенную от Intel. Пытаюсь создать новый xorg.conf через nvidia-xconfig и начинается трабл: WARNING: Unable to use the nvidia-cfg library to query NVIDIA hardware. ERROR: Unable to determine number of GPUs in system; cannot honor '--enable-all-gpus' option. Отключаю шестую карту, генерю xorg.conf – всё взлетает, добавляю 6-ую карту – xorg.conf не генерится. Решение нашёл здесь https://ubuntuforums.org/showthread.php?t=1684460 Сделал следующее: sudo nano /etc/default/grub нашёл там строку GRUB_CMDLINE_LINUX_DEFAULT="" и дописал в кавычках quiet splash GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" сохранился. Затем: sudo update-grub sudo reboot После ребута xorg.conf сгенерился с первого раза и всё заработало. P.S. На форуме, где я нашёл решение своей проблемы, у чувака в кавычках уже стояло quiet splash и он менял его на quiet splash vmalloc=256M , но мне хватило только добавления в пустые кавычки quiet splash.
  13. @Fabryan Может соединить 2 скрипта в один, а в нём между командами поставить задержку?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...